2 # DON'T REMOVE PREVIOUS LINE!!! libspec depends on it!
4 # Copyright (c) 1991-2005 Silicon Graphics, Inc. All Rights Reserved.
5 # Copyright (c) 2006-2010 The Khronos Group, Inc.
7 # This document is licensed under the SGI Free Software B License Version
8 # 2.0. For details, see http://oss.sgi.com/projects/FreeB/ .
10 # $Revision: 20495 $ on $Date: 2013-02-06 13:01:10 -0800 (Wed, 06 Feb 2013) $
13 param: retval retained
14 glxflags: client-handcode client-intercept server-handcode
17 category: VERSION_1_3 VERSION_1_4 ARB_get_proc_address ARB_multisample ARB_fbconfig_float EXT_import_context SGIX_dmbuffer SGIX_fbconfig SGIX_pbuffer SGIX_swap_barrier SGIX_swap_group SGIX_video_resize SGIX_video_source SGI_cushion SGI_make_current_read SGI_swap_control SGI_video_sync SUN_get_transparent_index MESA_agp_offset MESA_copy_sub_buffer MESA_pixmap_colormap MESA_release_buffers MESA_set_3dfx_mode SGIX_visual_select_group OML_sync_control SGIX_hyperpipe EXT_texture_from_pixmap NV_swap_group NV_video_output NV_present_video ARB_create_context NV_video_capture NV_copy_image EXT_swap_control ARB_framebuffer_sRGB
21 # Boilerplate to define types used by some extensions. This is done
22 # up front, since it involves some complexities in protecting
23 # the declarations whether or not the -protect flag is given to
24 # the generator scripts.
27 passthru: #ifndef GLX_ARB_get_proc_address
28 passthru: typedef void (*__GLXextFuncPtr)(void);
31 passthru: #ifndef GLX_SGIX_video_source
32 passthru: typedef XID GLXVideoSourceSGIX;
35 passthru: #ifndef GLX_SGIX_fbconfig
36 passthru: typedef XID GLXFBConfigIDSGIX;
37 passthru: typedef struct __GLXFBConfigRec *GLXFBConfigSGIX;
40 passthru: #ifndef GLX_SGIX_pbuffer
41 passthru: typedef XID GLXPbufferSGIX;
42 passthru: typedef struct {
44 passthru: unsigned long serial; /* # of last request processed by server */
45 passthru: Bool send_event; /* true if this came for SendEvent request */
46 passthru: Display *display; /* display the event was read from */
47 passthru: GLXDrawable drawable; /* i.d. of Drawable */
48 passthru: int event_type; /* GLX_DAMAGED_SGIX or GLX_SAVED_SGIX */
49 passthru: int draw_type; /* GLX_WINDOW_SGIX or GLX_PBUFFER_SGIX */
50 passthru: unsigned int mask; /* mask indicating which buffers are affected*/
52 passthru: int width, height;
53 passthru: int count; /* if nonzero, at least this many more */
54 passthru: } GLXBufferClobberEventSGIX;
57 passthru: #ifndef GLX_NV_video_output
58 passthru: typedef unsigned int GLXVideoDeviceNV;
61 passthru: #ifndef GLX_NV_video_capture
62 passthru: typedef XID GLXVideoCaptureDeviceNV;
65 passthru: #ifndef GLEXT_64_TYPES_DEFINED
66 passthru: /* This code block is duplicated in glext.h, so must be protected */
67 passthru: #define GLEXT_64_TYPES_DEFINED
68 passthru: /* Define int32_t, int64_t, and uint64_t types for UST/MSC */
69 passthru: /* (as used in the GLX_OML_sync_control extension). */
70 passthru: #if defined(__STDC_VERSION__) && __STDC_VERSION__ >= 199901L
71 passthru: #include <inttypes.h>
72 passthru: #elif defined(__sun__) || defined(__digital__)
73 passthru: #include <inttypes.h>
74 passthru: #if defined(__STDC__)
75 passthru: #if defined(__arch64__) || defined(_LP64)
76 passthru: typedef long int int64_t;
77 passthru: typedef unsigned long int uint64_t;
79 passthru: typedef long long int int64_t;
80 passthru: typedef unsigned long long int uint64_t;
81 passthru: #endif /* __arch64__ */
82 passthru: #endif /* __STDC__ */
83 passthru: #elif defined( __VMS ) || defined(__sgi)
84 passthru: #include <inttypes.h>
85 passthru: #elif defined(__SCO__) || defined(__USLC__)
86 passthru: #include <stdint.h>
87 passthru: #elif defined(__UNIXOS2__) || defined(__SOL64__)
88 passthru: typedef long int int32_t;
89 passthru: typedef long long int int64_t;
90 passthru: typedef unsigned long long int uint64_t;
91 passthru: #elif defined(_WIN32) && defined(__GNUC__)
92 passthru: #include <stdint.h>
93 passthru: #elif defined(_WIN32)
94 passthru: typedef __int32 int32_t;
95 passthru: typedef __int64 int64_t;
96 passthru: typedef unsigned __int64 uint64_t;
98 passthru: #include <inttypes.h> /* Fallback option */
103 ###############################################################################
107 ###############################################################################
109 GetFBConfigs(dpy, screen, nelements)
110 return GLXFBConfigPointer
111 param dpy Display in reference
112 param screen int in value
113 param nelements int out reference
115 glxflags client-handcode server-handcode
118 ChooseFBConfig(dpy, screen, attrib_list, nelements)
119 return GLXFBConfigPointer
120 param dpy Display in reference
121 param screen int in value
122 param attrib_list int in array []
123 param nelements int out reference
125 glxflags client-handcode client-intercept server-handcode
127 GetFBConfigAttrib(dpy, config, attribute, value)
129 param dpy Display in reference
130 param config GLXFBConfig in value
131 param attribute int in value
132 param value int out reference
134 glxflags client-handcode client-intercept server-handcode
136 GetVisualFromFBConfig(dpy, config)
137 return XVisualInfoPointer
138 param dpy Display in reference
139 param config GLXFBConfig in value
141 glxflags client-handcode client-intercept server-handcode
143 CreateWindow(dpy, config, win, attrib_list)
145 param dpy Display in reference
146 param config GLXFBConfig in value
147 param win Window in value
148 param attrib_list int in array []
150 glxflags client-handcode server-handcode
153 DestroyWindow(dpy, win)
155 param dpy Display in reference
156 param win GLXWindow in value
158 glxflags client-handcode server-handcode
161 CreatePixmap(dpy, config, pixmap, attrib_list)
163 param dpy Display in reference
164 param config GLXFBConfig in value
165 param pixmap Pixmap in value
166 param attrib_list int in array []
168 glxflags client-handcode server-handcode
171 DestroyPixmap(dpy, pixmap)
173 param dpy Display in reference
174 param pixmap GLXPixmap in value
176 glxflags client-handcode server-handcode
179 CreatePbuffer(dpy, config, attrib_list)
181 param dpy Display in reference
182 param config GLXFBConfig in value
183 param attrib_list int in array []
185 glxflags client-handcode server-handcode
188 DestroyPbuffer(dpy, pbuf)
190 param dpy Display in reference
191 param pbuf GLXPbuffer in value
193 glxflags client-handcode server-handcode
196 # glXGetDrawableAttributes -> GLX opcode 29
197 # glXChangeDrawableAttributes -> GLX opcode 30
199 # Uses glXGetDrawableAttributes protocol
200 QueryDrawable(dpy, draw, attribute, value)
202 param dpy Display in reference
203 param draw GLXDrawable in value
204 param attribute int in value
205 param value uint out reference
207 glxflags client-handcode client-intercept server-handcode
209 CreateNewContext(dpy, config, render_type, share_list, direct)
211 param dpy Display in reference
212 param config GLXFBConfig in value
213 param render_type int in value
214 param share_list GLXContext in value
215 param direct Bool in value
217 glxflags client-handcode server-handcode
220 MakeContextCurrent(dpy, draw, read, ctx)
222 param dpy Display in reference
223 param draw GLXDrawable in value
224 param read GLXDrawable in value
225 param ctx GLXContext in value
227 glxflags client-handcode server-handcode
230 GetCurrentReadDrawable()
233 glxflags client-handcode client-intercept server-handcode
236 return DisplayPointer
238 glxflags client-handcode client-intercept server-handcode
240 QueryContext(dpy, ctx, attribute, value)
242 param dpy Display in reference
243 param ctx GLXContext in value
244 param attribute int in value
245 param value int out reference
247 glxflags client-handcode server-handcode
250 # Uses glXChangeDrawableAttributes protocol
251 SelectEvent(dpy, draw, event_mask)
253 param dpy Display in reference
254 param draw GLXDrawable in value
255 param event_mask ulong in value
257 glxflags client-handcode server-handcode
259 # Uses glXGetDrawableAttributes protocol
260 GetSelectedEvent(dpy, draw, event_mask)
262 param dpy Display in reference
263 param draw GLXDrawable in value
264 param event_mask ulong out reference
266 glxflags client-handcode client-intercept server-handcode
268 ###############################################################################
272 ###############################################################################
274 GetProcAddress(procName)
275 return FunctionPointer
276 param procName GLubyte in reference
278 glxflags client-handcode client-intercept server-handcode
280 ###############################################################################
283 # ARB_get_proc_address commands
284 # @promoted to core in GLX 1.4, but there's no provision for aliasing
285 # @in GLX spec files, yet
287 ###############################################################################
289 GetProcAddressARB(procName)
290 return FunctionPointer
291 param procName GLubyte in reference
292 category ARB_get_proc_address
293 glxflags client-handcode client-intercept server-handcode
295 ###############################################################################
298 # ARB_multisample commands
300 ###############################################################################
303 newcategory: ARB_multisample
305 ###############################################################################
308 # ARB_fbconfig_float commands
310 ###############################################################################
313 newcategory: ARB_fbconfig_float
315 ###############################################################################
318 # ARB_framebuffer_sRGB commands
320 ###############################################################################
323 newcategory: ARB_framebuffer_sRGB
325 ###############################################################################
328 # ARB_create_context commands
330 ###############################################################################
332 CreateContextAttribsARB(dpy, config, share_context, direct, attrib_list)
334 param dpy Display in reference
335 param config GLXFBConfig in value
336 param share_context GLXContext in value
337 param direct Bool in value
338 param attrib_list int in array []
339 category ARB_create_context
340 glxflags client-handcode client-intercept server-handcode
343 ###############################################################################
346 # ARB_create_context_profile commands
348 ###############################################################################
351 newcategory: ARB_create_context_profile
353 ###############################################################################
356 # ARB_create_context_robustness commands
358 ###############################################################################
361 newcategory: ARB_create_context_robustness
364 ###############################################################################
367 # SGIS_multisample commands
369 ###############################################################################
372 newcategory: SGIS_multisample
374 ###############################################################################
377 # EXT_visual_info commands
379 ###############################################################################
382 newcategory: EXT_visual_info
384 ###############################################################################
387 # SGI_swap_control commands
389 ###############################################################################
391 SwapIntervalSGI(interval)
393 param interval int in value
394 category SGI_swap_control
395 glxflags client-handcode server-handcode
398 ###############################################################################
401 # SGI_video_sync commands
403 ###############################################################################
405 GetVideoSyncSGI(count)
407 param count uint out reference
408 category SGI_video_sync
409 glxflags client-handcode client-intercept server-handcode
411 WaitVideoSyncSGI(divisor, remainder, count)
413 param divisor int in value
414 param remainder int in value
415 param count uint out reference
416 category SGI_video_sync
417 glxflags client-handcode client-intercept server-handcode
419 ###############################################################################
422 # SGI_make_current_read commands
424 ###############################################################################
426 MakeCurrentReadSGI(dpy, draw, read, ctx)
428 param dpy Display in reference
429 param draw GLXDrawable in value
430 param read GLXDrawable in value
431 param ctx GLXContext in value
432 category SGI_make_current_read
433 glxflags client-handcode server-handcode
436 GetCurrentReadDrawableSGI()
438 category SGI_make_current_read
439 glxflags client-handcode client-intercept server-handcode
441 ###############################################################################
444 # SGIX_video_source commands
446 ###############################################################################
448 newcategory: SGIX_video_source
449 passthru: #ifdef _VL_H
451 CreateGLXVideoSourceSGIX(display, screen, server, path, nodeClass, drainNode)
452 return GLXVideoSourceSGIX
453 param display Display in reference
454 param screen int in value
455 param server VLServer in value
456 param path VLPath in value
457 param nodeClass int in value
458 param drainNode VLNode in value
459 category SGIX_video_source
460 glxflags client-handcode server-handcode
463 DestroyGLXVideoSourceSGIX(dpy, glxvideosource)
465 param dpy Display in reference
466 param glxvideosource GLXVideoSourceSGIX in value
467 category SGIX_video_source
468 glxflags client-handcode server-handcode
471 passend: #endif /* _VL_H */
474 ###############################################################################
477 # EXT_visual_rating commands
479 ###############################################################################
482 newcategory: EXT_visual_rating
484 ###############################################################################
487 # EXT_import_context commands
489 ###############################################################################
491 GetCurrentDisplayEXT()
492 return DisplayPointer
493 category EXT_import_context
494 glxflags client-handcode client-intercept server-handcode
496 QueryContextInfoEXT(dpy, context, attribute, value)
498 param dpy Display in reference
499 param context GLXContext in value
500 param attribute int in value
501 param value int out reference
502 category EXT_import_context
503 glxflags client-handcode server-handcode
506 # 'constGLXContext' is a hack; the extension specification and glx.h
507 # should be fixed instead.
508 GetContextIDEXT(context)
510 param context constGLXContext in value
511 category EXT_import_context
512 glxflags client-handcode client-intercept server-handcode
514 ImportContextEXT(dpy, contextID)
516 param dpy Display in reference
517 param contextID GLXContextID in value
518 category EXT_import_context
519 glxflags client-handcode client-intercept server-handcode
521 FreeContextEXT(dpy, context)
523 param dpy Display in reference
524 param context GLXContext in value
525 category EXT_import_context
526 glxflags client-handcode client-intercept server-handcode
528 ###############################################################################
531 # SGIX_fbconfig commands
533 ###############################################################################
535 # GetFBConfigsSGIX protocol -> VendorPrivate opcode 65540
537 GetFBConfigAttribSGIX(dpy, config, attribute, value)
539 param dpy Display in reference
540 param config GLXFBConfigSGIX in value
541 param attribute int in value
542 param value int out reference
543 category SGIX_fbconfig
544 glxflags client-handcode client-intercept server-handcode
546 ChooseFBConfigSGIX(dpy, screen, attrib_list, nelements)
547 return GLXFBConfigSGIXPointer
548 param dpy Display in reference
549 param screen int in value
550 param attrib_list int out reference
551 param nelements int out reference
552 category SGIX_fbconfig
553 glxflags client-handcode client-intercept server-handcode
555 CreateGLXPixmapWithConfigSGIX(dpy, config, pixmap)
557 param dpy Display in reference
558 param config GLXFBConfigSGIX in value
559 param pixmap Pixmap in value
560 category SGIX_fbconfig
561 glxflags client-handcode server-handcode
564 CreateContextWithConfigSGIX(dpy, config, render_type, share_list, direct)
566 param dpy Display in reference
567 param config GLXFBConfigSGIX in value
568 param render_type int in value
569 param share_list GLXContext in value
570 param direct Bool in value
571 category SGIX_fbconfig
572 glxflags client-handcode server-handcode
575 GetVisualFromFBConfigSGIX(dpy, config)
576 return XVisualInfoPointer
577 param dpy Display in reference
578 param config GLXFBConfigSGIX in value
579 category SGIX_fbconfig
580 glxflags client-handcode client-intercept server-handcode
582 GetFBConfigFromVisualSGIX(dpy, vis)
583 return GLXFBConfigSGIX
584 param dpy Display in reference
585 param vis XVisualInfo out reference
586 category SGIX_fbconfig
587 glxflags client-handcode client-intercept server-handcode
589 ###############################################################################
592 # SGIX_pbuffer commands
594 ###############################################################################
596 # ChangeDrawableAttributesSGIX protocol -> VendorPrivate opcode 65545
597 # GetDrawableAttributesSGIX protocol -> VendorPrivate opcode 65546
599 CreateGLXPbufferSGIX(dpy, config, width, height, attrib_list)
600 return GLXPbufferSGIX
601 param dpy Display in reference
602 param config GLXFBConfigSGIX in value
603 param width uint in value
604 param height uint in value
605 param attrib_list int out reference
606 category SGIX_pbuffer
607 glxflags client-handcode server-handcode
610 DestroyGLXPbufferSGIX(dpy, pbuf)
612 param dpy Display in reference
613 param pbuf GLXPbufferSGIX in value
614 category SGIX_pbuffer
615 glxflags client-handcode
618 QueryGLXPbufferSGIX(dpy, pbuf, attribute, value)
620 param dpy Display in reference
621 param pbuf GLXPbufferSGIX in value
622 param attribute int in value
623 param value uint out reference
624 category SGIX_pbuffer
626 SelectEventSGIX(dpy, drawable, mask)
628 param dpy Display in reference
629 param drawable GLXDrawable in value
630 param mask ulong in value
631 category SGIX_pbuffer
633 GetSelectedEventSGIX(dpy, drawable, mask)
635 param dpy Display in reference
636 param drawable GLXDrawable in value
637 param mask ulong out reference
638 category SGIX_pbuffer
640 ###############################################################################
643 # SGI_cushion commands
645 ###############################################################################
647 CushionSGI(dpy, window, cushion)
649 param dpy Display in reference
650 param window Window in value
651 param cushion float in value
654 ###############################################################################
657 # SGIX_video_resize commands
659 ###############################################################################
661 BindChannelToWindowSGIX(display, screen, channel, window)
663 param display Display in reference
664 param screen int in value
665 param channel int in value
666 param window Window in value
667 category SGIX_video_resize
669 ChannelRectSGIX(display, screen, channel, x, y, w, h)
671 param display Display in reference
672 param screen int in value
673 param channel int in value
678 category SGIX_video_resize
680 QueryChannelRectSGIX(display, screen, channel, dx, dy, dw, dh)
682 param display Display in reference
683 param screen int in value
684 param channel int in value
685 param dx int out reference
686 param dy int out reference
687 param dw int out reference
688 param dh int out reference
689 category SGIX_video_resize
691 QueryChannelDeltasSGIX(display, screen, channel, x, y, w, h)
693 param display Display in reference
694 param screen int in value
695 param channel int in value
696 param x int out reference
697 param y int out reference
698 param w int out reference
699 param h int out reference
700 category SGIX_video_resize
702 # @@@ Not in man page - this entry point may not be shipping?
703 ChannelRectSyncSGIX(display, screen, channel, synctype)
705 param display Display in reference
706 param screen int in value
707 param channel int in value
708 param synctype GLenum in value
709 category SGIX_video_resize
711 ###############################################################################
714 # SGIX_dmbuffer commands
716 ###############################################################################
718 newcategory: SGIX_dmbuffer
719 passthru: #ifdef _DM_BUFFER_H_
721 AssociateDMPbufferSGIX(dpy, pbuffer, params, dmbuffer)
723 param dpy Display in reference
724 param pbuffer GLXPbufferSGIX in value
725 param params DMparams out reference
726 param dmbuffer DMbuffer in value
727 category SGIX_dmbuffer
729 passend: #endif /* _DM_BUFFER_H_ */
732 ###############################################################################
735 # SGIX_swap_group commands
737 ###############################################################################
739 JoinSwapGroupSGIX(dpy, drawable, member)
741 param dpy Display in reference
742 param drawable GLXDrawable in value
743 param member GLXDrawable in value
744 category SGIX_swap_group
745 glxflags client-handcode server-handcode
748 ###############################################################################
751 # SGIX_swap_barrier commands
753 ###############################################################################
755 BindSwapBarrierSGIX(dpy, drawable, barrier)
757 param dpy Display in reference
758 param drawable GLXDrawable in value
759 param barrier int in value
760 category SGIX_swap_barrier
761 glxflags client-handcode server-handcode
764 QueryMaxSwapBarriersSGIX(dpy, screen, max)
766 param dpy Display in reference
767 param screen int in value
768 param max int out reference
769 category SGIX_swap_barrier
770 glxflags client-handcode server-handcode
773 ###############################################################################
776 # SUN_get_transparent_index commands
778 ###############################################################################
780 GetTransparentIndexSUN(dpy, overlay, underlay, pTransparentIndex)
782 param dpy Display in reference
783 param overlay Window in value
784 param underlay Window in value
785 param pTransparentIndex long out reference
786 category SUN_get_transparent_index
788 ###############################################################################
791 # MESA_copy_sub_buffer commands
793 ###############################################################################
795 CopySubBufferMESA(dpy, drawable, x, y, width, height)
797 param dpy Display in reference
798 param drawable GLXDrawable in value
801 param width int in value
802 param height int in value
803 category MESA_copy_sub_buffer
804 glxflags client-handcode client-intercept server-handcode
806 ###############################################################################
809 # MESA_pixmap_colormap commands
811 ###############################################################################
813 CreateGLXPixmapMESA(dpy, visual, pixmap, cmap)
815 param dpy Display in reference
816 param visual XVisualInfo out reference
817 param pixmap Pixmap in value
818 param cmap Colormap in value
819 category MESA_pixmap_colormap
820 glxflags client-handcode client-intercept server-handcode
822 ###############################################################################
825 # MESA_release_buffers commands
827 ###############################################################################
829 ReleaseBuffersMESA(dpy, drawable)
831 param dpy Display in reference
832 param drawable GLXDrawable in value
833 category MESA_release_buffers
834 glxflags client-handcode client-intercept server-handcode
836 ###############################################################################
839 # MESA_set_3dfx_mode commands
841 ###############################################################################
843 # Brian's spec has this as returning 'GLboolean' and taking 'GLint mode'
844 Set3DfxModeMESA(mode)
846 param mode int in value
847 category MESA_set_3dfx_mode
848 glxflags client-handcode client-intercept server-handcode
850 ###############################################################################
853 # SGIX_visual_select_group commands
855 ###############################################################################
858 newcategory: SGIX_visual_select_group
860 ###############################################################################
863 # OML_swap_method commands
865 ###############################################################################
868 newcategory: OML_swap_method
870 ###############################################################################
873 # OML_sync_control commands
875 ###############################################################################
877 GetSyncValuesOML(dpy, drawable, ust, msc, sbc)
879 param dpy Display in reference
880 param drawable GLXDrawable in value
881 param ust int64_t out reference
882 param msc int64_t out reference
883 param sbc int64_t out reference
884 category OML_sync_control
885 glxflags client-handcode server-handcode
887 GetMscRateOML(dpy, drawable, numerator, denominator)
889 param dpy Display in reference
890 param drawable GLXDrawable in value
891 param numerator int32_t out reference
892 param denominator int32_t out reference
893 category OML_sync_control
894 glxflags client-handcode server-handcode
896 SwapBuffersMscOML(dpy, drawable, target_msc, divisor, remainder)
898 param dpy Display in reference
899 param drawable GLXDrawable in value
900 param target_msc int64_t in value
901 param divisor int64_t in value
902 param remainder int64_t in value
903 category OML_sync_control
904 glxflags client-handcode server-handcode
906 WaitForMscOML(dpy, drawable, target_msc, divisor, remainder, ust, msc, sbc)
908 param dpy Display in reference
909 param drawable GLXDrawable in value
910 param target_msc int64_t in value
911 param divisor int64_t in value
912 param remainder int64_t in value
913 param ust int64_t out reference
914 param msc int64_t out reference
915 param sbc int64_t out reference
916 category OML_sync_control
917 glxflags client-handcode server-handcode
919 WaitForSbcOML(dpy, drawable, target_sbc, ust, msc, sbc)
921 param dpy Display in reference
922 param drawable GLXDrawable in value
923 param target_sbc int64_t in value
924 param ust int64_t out reference
925 param msc int64_t out reference
926 param sbc int64_t out reference
927 category OML_sync_control
928 glxflags client-handcode server-handcode
930 ###############################################################################
933 # NV_float_buffer commands
935 ###############################################################################
938 newcategory: NV_float_buffer
940 ###############################################################################
943 # SGIX_hyperpipe commands
945 ###############################################################################
947 newcategory: SGIX_hyperpipe
949 passthru: typedef struct {
950 passthru: char pipeName[GLX_HYPERPIPE_PIPE_NAME_LENGTH_SGIX];
951 passthru: int networkId;
952 passthru: } GLXHyperpipeNetworkSGIX;
954 passthru: typedef struct {
955 passthru: char pipeName[GLX_HYPERPIPE_PIPE_NAME_LENGTH_SGIX];
956 passthru: int channel;
957 passthru: unsigned int
958 passthru: participationType;
959 passthru: int timeSlice;
960 passthru: } GLXHyperpipeConfigSGIX;
962 passthru: typedef struct {
963 passthru: char pipeName[GLX_HYPERPIPE_PIPE_NAME_LENGTH_SGIX];
964 passthru: int srcXOrigin, srcYOrigin, srcWidth, srcHeight;
965 passthru: int destXOrigin, destYOrigin, destWidth, destHeight;
966 passthru: } GLXPipeRect;
968 passthru: typedef struct {
969 passthru: char pipeName[GLX_HYPERPIPE_PIPE_NAME_LENGTH_SGIX];
970 passthru: int XOrigin, YOrigin, maxHeight, maxWidth;
971 passthru: } GLXPipeRectLimits;
974 QueryHyperpipeNetworkSGIX(dpy, npipes)
975 return GLXHyperpipeNetworkSGIXPointer
976 param dpy Display in reference
977 param npipes int out reference
978 glxflags client-handcode server-handcode
979 category SGIX_hyperpipe
982 HyperpipeConfigSGIX(dpy, networkId, npipes, cfg, hpId)
984 param dpy Display in reference
985 param networkId int in value
986 param npipes int in value
987 param cfg GLXHyperpipeConfigSGIX out array [COMPSIZE(npipes)]
988 param hpId int out reference
989 glxflags client-handcode server-handcode
990 category SGIX_hyperpipe
993 QueryHyperpipeConfigSGIX(dpy, hpId, npipes)
994 return GLXHyperpipeConfigSGIXPointer
995 param dpy Display in reference
996 param hpId int in value
997 param npipes int out reference
998 glxflags client-handcode server-handcode
999 category SGIX_hyperpipe
1002 DestroyHyperpipeConfigSGIX(dpy, hpId)
1004 param dpy Display in reference
1005 param hpId int in value
1006 glxflags client-handcode server-handcode
1007 category SGIX_hyperpipe
1010 BindHyperpipeSGIX(dpy, hpId)
1012 param dpy Display in reference
1013 param hpId int in value
1014 glxflags client-handcode server-handcode
1015 category SGIX_hyperpipe
1018 QueryHyperpipeBestAttribSGIX(dpy, timeSlice, attrib, size, attribList, returnAttribList)
1020 param dpy Display in reference
1021 param timeSlice int in value
1022 param attrib int in value
1023 param size int in value
1024 param attribList void out array [COMPSIZE(size)]
1025 param returnAttribList void out array [COMPSIZE(size)]
1026 glxflags client-handcode server-handcode
1027 category SGIX_hyperpipe
1030 HyperpipeAttribSGIX(dpy, timeSlice, attrib, size, attribList)
1032 param dpy Display in reference
1033 param timeSlice int in value
1034 param attrib int in value
1035 param size int in value
1036 param attribList void out array [COMPSIZE(size)]
1037 glxflags client-handcode server-handcode
1038 category SGIX_hyperpipe
1041 QueryHyperpipeAttribSGIX(dpy, timeSlice, attrib, size, returnAttribList)
1043 param dpy Display in reference
1044 param timeSlice int in value
1045 param attrib int in value
1046 param size int in value
1047 param returnAttribList void out array [COMPSIZE(size)]
1048 glxflags client-handcode server-handcode
1049 category SGIX_hyperpipe
1052 ###############################################################################
1055 # MESA_agp_offset commands
1057 ###############################################################################
1059 GetAGPOffsetMESA(pointer)
1061 param pointer void in reference
1062 glxflags client-handcode client-intercept server-handcode
1063 category MESA_agp_offset
1065 ###############################################################################
1068 # EXT_fbconfig_packed_float commands
1070 ###############################################################################
1073 newcategory: EXT_fbconfig_packed_float
1075 ###############################################################################
1078 # EXT_framebuffer_sRGB commands
1080 ###############################################################################
1083 newcategory: EXT_framebuffer_sRGB
1085 ###############################################################################
1088 # EXT_texture_from_pixmap commands
1090 ###############################################################################
1092 BindTexImageEXT(dpy, drawable, buffer, attrib_list)
1094 param dpy Display in reference
1095 param drawable GLXDrawable in value
1096 param buffer int in value
1097 param attrib_list int in array []
1098 category EXT_texture_from_pixmap
1099 glxflags client-handcode server-handcode
1102 ReleaseTexImageEXT(dpy, drawable, buffer)
1104 param dpy Display in reference
1105 param drawable GLXDrawable in value
1106 param buffer int in value
1107 category EXT_texture_from_pixmap
1108 glxflags client-handcode server-handcode
1111 ###############################################################################
1114 # NV_present_video commands
1116 ###############################################################################
1118 EnumerateVideoDevicesNV(dpy, screen, nelements)
1120 param dpy Display in reference
1121 param screen int in value
1122 param nelements int out reference
1123 category NV_present_video
1124 glxflags client-handcode server-handcode
1126 BindVideoDeviceNV(dpy, video_slot, video_device, attrib_list)
1128 param dpy Display in reference
1129 param video_slot uint in value
1130 param video_device uint in value
1131 param attrib_list int in array []
1132 category NV_present_video
1133 glxflags client-handcode server-handcode
1135 ###############################################################################
1138 # NV_video_output commands
1140 ###############################################################################
1142 GetVideoDeviceNV(dpy, screen, numVideoDevices, pVideoDevice)
1144 param dpy Display in reference
1145 param screen int in value
1146 param numVideoDevices int in value
1147 param pVideoDevice GLXVideoDeviceNV out array [COMPSIZE(numVideoDevices)]
1148 category NV_video_output
1149 glxflags client-handcode server-handcode
1152 ReleaseVideoDeviceNV(dpy, screen, VideoDevice)
1154 param dpy Display in reference
1155 param screen int in value
1156 param VideoDevice GLXVideoDeviceNV in value
1157 category NV_video_output
1158 glxflags client-handcode server-handcode
1161 BindVideoImageNV(dpy, VideoDevice, pbuf, iVideoBuffer)
1163 param dpy Display in reference
1164 param VideoDevice GLXVideoDeviceNV in value
1165 param pbuf GLXPbuffer in value
1166 param iVideoBuffer int in value
1167 category NV_video_output
1168 glxflags client-handcode server-handcode
1171 ReleaseVideoImageNV(dpy, pbuf)
1173 param dpy Display in reference
1174 param pbuf GLXPbuffer in value
1175 category NV_video_output
1176 glxflags client-handcode server-handcode
1179 SendPbufferToVideoNV(dpy, pbuf, iBufferType, pulCounterPbuffer, bBlock)
1181 param dpy Display in reference
1182 param pbuf GLXPbuffer in value
1183 param iBufferType int in value
1184 param pulCounterPbuffer ulong out reference
1185 param bBlock GLboolean in value
1186 category NV_video_output
1187 glxflags client-handcode server-handcode
1190 GetVideoInfoNV(dpy, screen, VideoDevice, pulCounterOutputPbuffer, pulCounterOutputVideo)
1192 param dpy Display in reference
1193 param screen int in value
1194 param VideoDevice GLXVideoDeviceNV in value
1195 param pulCounterOutputPbuffer ulong out reference
1196 param pulCounterOutputVideo ulong out reference
1197 category NV_video_output
1198 glxflags client-handcode server-handcode
1201 ###############################################################################
1204 # NV_swap_group commands
1206 ###############################################################################
1208 JoinSwapGroupNV(dpy, drawable, group)
1210 param dpy Display in reference
1211 param drawable GLXDrawable in value
1212 param group GLuint in value
1213 category NV_swap_group
1214 glxflags client-handcode server-handcode
1216 BindSwapBarrierNV(dpy, group, barrier)
1218 param dpy Display in reference
1219 param group GLuint in value
1220 param barrier GLuint in value
1221 category NV_swap_group
1222 glxflags client-handcode server-handcode
1224 QuerySwapGroupNV(dpy, drawable, group, barrier)
1226 param dpy Display in reference
1227 param drawable GLXDrawable in value
1228 param group GLuint out reference
1229 param barrier GLuint out reference
1230 category NV_swap_group
1231 glxflags client-handcode server-handcode
1233 QueryMaxSwapGroupsNV(dpy, screen, maxGroups, maxBarriers)
1235 param dpy Display in reference
1236 param screen int in value
1237 param maxGroups GLuint out reference
1238 param maxBarriers GLuint out reference
1239 category NV_swap_group
1240 glxflags client-handcode server-handcode
1242 QueryFrameCountNV(dpy, screen, count)
1244 param dpy Display in reference
1245 param screen int in value
1246 param count GLuint out reference
1247 category NV_swap_group
1248 glxflags client-handcode server-handcode
1250 ResetFrameCountNV(dpy, screen)
1252 param dpy Display in reference
1253 param screen int in value
1254 category NV_swap_group
1255 glxflags client-handcode server-handcode
1257 ###############################################################################
1260 # NV_video_capture commands
1262 ###############################################################################
1264 BindVideoCaptureDeviceNV(dpy, video_capture_slot, device)
1266 param dpy Display in reference
1267 param video_capture_slot uint in value
1268 param device GLXVideoCaptureDeviceNV in value
1269 category NV_video_capture
1270 glxflags client-handcode server-handcode
1272 EnumerateVideoCaptureDevicesNV(dpy, screen, nelements)
1273 return GLXVideoCaptureDeviceNVPointer
1274 param dpy Display in reference
1275 param screen int in value
1276 param nelements int out reference
1277 category NV_video_capture
1278 glxflags client-handcode server-handcode
1280 LockVideoCaptureDeviceNV(dpy, device)
1282 param dpy Display in reference
1283 param device GLXVideoCaptureDeviceNV in value
1284 category NV_video_capture
1285 glxflags client-handcode server-handcode
1287 QueryVideoCaptureDeviceNV(dpy, device, attribute, value)
1289 param dpy Display in reference
1290 param device GLXVideoCaptureDeviceNV in value
1291 param attribute int in value
1292 param value int out array [COMPSIZE(attribute)]
1293 category NV_video_capture
1294 glxflags client-handcode server-handcode
1296 ReleaseVideoCaptureDeviceNV(dpy, device)
1298 param dpy Display in reference
1299 param device GLXVideoCaptureDeviceNV in value
1300 category NV_video_capture
1301 glxflags client-handcode server-handcode
1303 ###############################################################################
1306 # EXT_swap_control commands
1308 ###############################################################################
1310 SwapIntervalEXT(dpy, drawable, interval)
1312 param dpy Display in reference
1313 param drawable GLXDrawable in value
1314 param interval int in value
1315 category EXT_swap_control
1316 glxflags client-handcode server-handcode
1319 ###############################################################################
1322 # NV_copy_image commands
1324 ###############################################################################
1326 CopyImageSubDataNV(dpy, srcCtx, srcName, srcTarget, srcLevel, srcX, srcY, srcZ, dstCtx, dstName, dstTarget, dstLevel, dstX, dstY, dstZ, width, height, depth)
1328 param dpy Display in reference
1329 param srcCtx GLXContext in value
1330 param srcName GLuint in value
1331 param srcTarget GLenum in value
1332 param srcLevel GLint in value
1333 param srcX GLint in value
1334 param srcY GLint in value
1335 param srcZ GLint in value
1336 param dstCtx GLXContext in value
1337 param dstName GLuint in value
1338 param dstTarget GLenum in value
1339 param dstLevel GLint in value
1340 param dstX GLint in value
1341 param dstY GLint in value
1342 param dstZ GLint in value
1343 param width GLsizei in value
1344 param height GLsizei in value
1345 param depth GLsizei in value
1346 category NV_copy_image
1348 glxflags client-handcode server-handcode
1350 ###############################################################################
1353 # INTEL_swap_event commands
1355 ###############################################################################
1358 newcategory: INTEL_swap_event
1360 ###############################################################################
1363 # NV_multisample_coverage commands
1365 ###############################################################################
1368 newcategory: NV_multisample_coverage
1370 ###############################################################################
1373 # AMD_gpu_association commands
1375 ###############################################################################
1377 # These are a weird mishmash of X and Windows types - are they correct?
1378 # Leave out of glxext.h for the time being.
1380 #@ UINT glXGetGPUIDsAMD(UINT maxCount, UINT *ids);
1381 #@ INT glXGetGPUInfoAMD(UINT id, INT property, GLenum dataType,
1382 #@ UINT size, void *data)
1383 #@ UINT glXGetContextGPUIDAMD(GLXContext ctx);
1384 #@ HGLRC glXCreateAssociatedContextAMD(UINT id, GLXContext share_list);
1385 #@ HGLRC glXCreateAssociatedContextAttribsAMD(UINT id, GLXContext share_context,
1386 #@ const int *attribList);
1387 #@ BOOL glXDeleteAssociatedContextAMD(GLXContext ctx);
1388 #@ BOOL glXMakeAssociatedContextCurrentAMD(GLXContext ctx);
1389 #@ HGLRC glXGetCurrentAssociatedContextAMD(void);
1390 #@ VOID glXBlitContextFramebufferAMD(GLXContext dstCtx, GLint srcX0, GLint srcY0,
1391 #@ GLint srcX1, GLint srcY1, GLint dstX0,
1392 #@ GLint dstY0, GLint dstX1, GLint dstY1,
1393 #@ GLbitfield mask, GLenum filter);
1395 #@ glXGetGPUIDsAMD(maxCount, ids)
1397 #@ param maxCount UINT in value
1398 #@ param ids UINT in array [???]
1399 #@ category AMD_gpu_association
1406 #@ glXGetGPUInfoAMD(id, property, dataType, size, data)
1408 #@ param id UINT in value
1409 #@ param property INT in value
1410 #@ param dataType GLenum in value
1411 #@ param size UINT in value
1412 #@ param data void in array [???]
1413 #@ category AMD_gpu_association
1420 #@ glXGetContextGPUIDAMD(ctx)
1422 #@ param ctx GLXContext in value
1423 #@ category AMD_gpu_association
1430 #@ glXCreateAssociatedContextAMD(id, share_list)
1432 #@ param id UINT in value
1433 #@ param share_list GLXContext in value
1434 #@ category AMD_gpu_association
1441 #@ glXCreateAssociatedContextAttribsAMD(id, share_context, attribList)
1443 #@ param id UINT in value
1444 #@ param share_context GLXContext in value
1445 #@ param attribList Int32 in array [???]
1446 #@ category AMD_gpu_association
1453 #@ glXDeleteAssociatedContextAMD(ctx)
1455 #@ param ctx GLXContext in value
1456 #@ category AMD_gpu_association
1463 #@ glXMakeAssociatedContextCurrentAMD(ctx)
1465 #@ param ctx GLXContext in value
1466 #@ category AMD_gpu_association
1473 #@ glXGetCurrentAssociatedContextAMD()
1475 #@ category AMD_gpu_association
1482 #@ glXBlitContextFramebufferAMD(dstCtx, srcX0, srcY0, srcX1, srcY1, dstX0, dstY0, dstX1, dstY1, mask, filter)
1484 #@ param dstCtx GLXContext in value
1485 #@ param srcX0 GLint in value
1486 #@ param srcY0 GLint in value
1487 #@ param srcX1 GLint in value
1488 #@ param srcY1 GLint in value
1489 #@ param dstX0 GLint in value
1490 #@ param dstY0 GLint in value
1491 #@ param dstX1 GLint in value
1492 #@ param dstY1 GLint in value
1493 #@ param mask GLbitfield in value
1494 #@ param filter GLenum in value
1495 #@ category AMD_gpu_association
1502 ###############################################################################
1505 # EXT_create_context_es2_profile commands
1506 # EXT_create_context_es_profile commands
1508 ###############################################################################
1511 newcategory: EXT_create_context_es2_profile
1513 newcategory: EXT_create_context_es_profile
1515 ###############################################################################
1518 # EXT_swap_control_tear commands
1520 ###############################################################################
1523 newcategory: EXT_swap_control_tear
1525 ###############################################################################
1528 # EXT_buffer_age commands
1530 ###############################################################################
1533 newcategory: EXT_buffer_age