]> git.notmuchmail.org Git - notmuch/blob - packaging/fedora/notmuch.spec
packaging: fedora: remove irrelevant stuff
[notmuch] / packaging / fedora / notmuch.spec
1 %global git 6b9a717c
2 %global date %(date +%Y%m%d)
3
4 # If you are doing a git snapshot:
5 #
6 # Release should be 1%{git}%{?dist}
7 # Source0 should be notmuch-%{version}-%{git}.tar.gz
8 # git version is generated by 'git show-ref --hash=8 HEAD'
9 #
10 # To create a tarball:
11 #
12 # git clone git://notmuchmail.org/git/notmuch
13 # cd notmuch
14 # git archive --format=tar --prefix=notmuch-0.4/ HEAD | gzip > notmuch-0.4-`git show-ref --hash=8 HEAD`.tar.gz
15 #
16
17 Name:           notmuch
18 Version:        0.15.2
19 Release:        1%{?dist}
20 Summary:        Not much of an email program
21
22 Group:          Applications/Internet
23 License:        GPLv3+
24 URL:            http://notmuchmail.org/
25
26 Source0:        http://notmuchmail.org/releases/notmuch-%{version}.tar.gz
27 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
28
29 BuildRequires:  xapian-core-devel
30 BuildRequires:  gmime-devel
31 BuildRequires:  libtalloc-devel
32 BuildRequires:  zlib-devel
33 BuildRequires:  emacs-el
34 BuildRequires:  emacs-nox
35
36 Requires:       emacs(bin) >= %{_emacs_version}
37
38 %description
39 * "Not much mail" is what Notmuch thinks about your email
40   collection. Even if you receive 12000 messages per month or have on
41   the order of millions of messages that you've been saving for
42   decades. Regardless, Notmuch will be able to quickly search all of
43   it. It's just plain not much mail.
44
45 * "Not much mail" is also what you should have in your inbox at any
46   time. Notmuch gives you what you need, (tags and fast search), so
47   that you can keep your inbox tamed and focus on what really matters
48   in your life, (which is surely not email).
49
50 * Notmuch is an answer to Sup. Sup is a very good email program
51   written by William Morgan (and others) and is the direct inspiration
52   for Notmuch. Notmuch began as an effort to rewrite
53   performance-critical pieces of Sup in C rather than ruby. From
54   there, it grew into a separate project. One significant contribution
55   Notmuch makes compared to Sup is the separation of the
56   indexer/searcher from the user interface. (Notmuch provides a
57   library interface so that its indexing/searching/tagging features
58   can be integrated into any email program.)
59
60 * Notmuch is not much of an email program. It doesn't receive messages
61   (no POP or IMAP support). It doesn't send messages (no mail composer,
62   no network code at all). And for what it does do (email search) that
63   work is provided by an external library, Xapian. So if Notmuch
64   provides no user interface and Xapian does all the heavy lifting,
65   then what's left here? Not much.
66
67 Notmuch is still in the early stages of development, but it does
68 include one user interface, (implemented within Emacs), which has at
69 least two users using it for reading all of their incoming mail. If
70 you've been looking for a fast, global-search and tag-based email
71 reader to use within Emacs, then Notmuch may be exactly what you've
72 been looking for.
73
74 Otherwise, if you're a developer of an existing email program and
75 would love a good library interface for fast, global search with
76 support for arbitrary tags, then Notmuch also may be exactly what
77 you've been looking for.
78
79 %package        devel
80 Summary:        Development files for %{name}
81 Group:          Development/Libraries
82 Requires:       %{name} = %{version}-%{release}
83
84 %description    devel
85 The %{name}-devel package contains libraries and header files for
86 developing applications that use %{name}.
87
88 %prep
89 %setup -q
90
91 %build
92 ./configure --prefix=%{_prefix} --libdir=%{_libdir} --sysconfdir=%{_sysconfdir} \
93     --mandir=%{_mandir} --includedir=%{_includedir} --emacslispdir=%{_emacs_sitelispdir}
94 make %{?_smp_mflags} CFLAGS="%{optflags}"
95
96 %install
97 make install DESTDIR=%{buildroot}
98
99 %clean
100 rm -rf %{buildroot}
101
102 %post -p /sbin/ldconfig
103
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(-,root,root,-)
108 %doc AUTHORS COPYING COPYING-GPL-3 INSTALL README
109
110 %{_bindir}/notmuch
111 %{_libdir}/libnotmuch.so.3*
112 %{_mandir}/man?/*
113
114 %{_emacs_sitelispdir}/*
115
116 %{_datarootdir}/zsh/functions/Completion/Unix/_notmuch
117 %{_sysconfdir}/bash_completion.d/notmuch
118
119 %files devel
120 %defattr(-,root,root,-)
121 %doc AUTHORS COPYING COPYING-GPL-3 INSTALL README
122 %{_includedir}/*
123 %{_libdir}/*.so
124
125
126 %changelog
127 * Sun Apr 28 2013 Felipe Contreras <felipe.contreras@gmail.com> - 0.15.2-1
128 - Update to latest upstream
129
130 * Tue Nov  2 2010 Scott Henson <shenson@redhat.com> - 0.4-1
131 - New upstream release
132
133 * Wed Nov 18 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.0-0.3.306635c2
134 - First version
135