]> git.notmuchmail.org Git - notmuch/blob - packaging/fedora/notmuch.spec
bc0a58ccb417b6aad43cc432981fdb4f810d5df3
[notmuch] / packaging / fedora / notmuch.spec
1 %global git 6b9a717c
2 %global date %(date +%Y%m%d)
3
4 # If you are doing a git snapshot:
5 #
6 # Release should be 1%{git}%{?dist}
7 # Source0 should be notmuch-%{version}-%{git}.tar.gz
8 # git version is generated by 'git show-ref --hash=8 HEAD'
9 #
10 # To create a tarball:
11 #
12 # git clone git://notmuchmail.org/git/notmuch
13 # cd notmuch
14 # git archive --format=tar --prefix=notmuch-0.4/ HEAD | gzip > notmuch-0.4-`git show-ref --hash=8 HEAD`.tar.gz
15 #
16
17 Name:           notmuch
18 Version:        0.15.2
19 Release:        1%{?dist}
20 Summary:        Thread-based email index, search and tagging
21
22 Group:          Applications/Internet
23 License:        GPLv3+
24 URL:            http://notmuchmail.org/
25
26 Source0:        http://notmuchmail.org/releases/notmuch-%{version}.tar.gz
27
28 BuildRequires:  xapian-core-devel gmime-devel libtalloc-devel
29 BuildRequires:  zlib-devel emacs-el emacs-nox python
30
31 %description
32 Fast system for indexing, searching, and tagging email.  Even if you
33 receive 12000 messages per month or have on the order of millions of
34 messages that you've been saving for decades, Notmuch will be able to
35 quickly search all of it.
36
37 Notmuch is not much of an email program. It doesn't receive messages
38 (no POP or IMAP support). It doesn't send messages (no mail composer,
39 no network code at all). And for what it does do (email search) that
40 work is provided by an external library, Xapian. So if Notmuch
41 provides no user interface and Xapian does all the heavy lifting, then
42 what's left here? Not much.
43
44 %package devel
45 Summary:        Development libraries and header files for %{name}
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48
49 %description devel
50 The %{name}-devel package contains libraries and header files for
51 developing applications that use %{name}.
52
53 %package -n emacs-notmuch
54 Summary:        Not much support for Emacs
55 Group:          Applications/Editors
56 BuildArch:      noarch
57 Requires:       %{name} = %{version}-%{release}, emacs(bin) >= %{_emacs_version}
58
59 %description -n emacs-notmuch
60 %{summary}.
61
62 %package -n python-notmuch
63 Summary:        Python bindings for notmuch
64 Group:          Development/Libraries
65 BuildArch:      noarch
66 Requires:       %{name} = %{version}-%{release}
67
68 %description -n python-notmuch
69 %{summary}.
70
71 %prep
72 %setup -q
73
74 %build
75 ./configure --prefix=%{_prefix} --libdir=%{_libdir} --sysconfdir=%{_sysconfdir} \
76     --mandir=%{_mandir} --includedir=%{_includedir} --emacslispdir=%{_emacs_sitelispdir}
77 make %{?_smp_mflags} CFLAGS="%{optflags}"
78
79 pushd bindings/python
80     python setup.py build
81 popd
82
83 %install
84 make install DESTDIR=%{buildroot}
85
86 pushd bindings/python
87     python setup.py install -O1 --skip-build --root %{buildroot}
88 popd
89
90 %post -p /sbin/ldconfig
91
92 %postun -p /sbin/ldconfig
93
94 %files
95 %doc AUTHORS COPYING COPYING-GPL-3 INSTALL README
96 %{_sysconfdir}/bash_completion.d/notmuch
97 %{_datadir}/zsh/functions/Completion/Unix/_notmuch
98 %{_bindir}/notmuch
99 %{_mandir}/man?/*
100 %{_libdir}/libnotmuch.so.3*
101
102 %files devel
103 %{_libdir}/libnotmuch.so
104 %{_includedir}/*
105
106 %files -n emacs-notmuch
107 %{_emacs_sitelispdir}/*
108
109 %files -n python-notmuch
110 %doc bindings/python/README
111 %{python_sitelib}/*
112
113
114 %changelog
115 * Sun Apr 28 2013 Felipe Contreras <felipe.contreras@gmail.com> - 0.15.2-1
116 - Update to latest upstream
117
118 * Tue Nov  2 2010 Scott Henson <shenson@redhat.com> - 0.4-1
119 - New upstream release
120
121 * Wed Nov 18 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.0-0.3.306635c2
122 - First version
123