]> git.notmuchmail.org Git - notmuch/blob - packaging/fedora/notmuch.spec
Merge Sebastian Spaeth's python bindings into bindings/python
[notmuch] / packaging / fedora / notmuch.spec
1 %global git 306635c2
2
3 %if %($(pkg-config emacs) ; echo $?)
4 %global emacs_version 23.1
5 %global emacs_lispdir %{_datadir}/emacs/site-lisp
6 %global emacs_startdir %{_datadir}/emacs/site-lisp/site-start.d
7 %else
8 %global emacs_version %(pkg-config emacs --modversion)
9 %global emacs_lispdir %(pkg-config emacs --variable sitepkglispdir)
10 %global emacs_startdir %(pkg-config emacs --variable sitestartdir)
11 %endif
12
13 Name:           notmuch
14 Version:        0.0
15 Release:        0.3.%{git}%{?dist}
16 Summary:        Not much of an email program
17
18 Group:          Applications/Internet
19 License:        GPLv3+
20 URL:            http://notmuchmail.org/
21
22 #
23 # To create a tarball:
24 #
25 # git clone git://notmuchmail.org/git/notmuch
26 # cd notmuch
27 # git archive --format=tar --prefix=notmuch/ HEAD | bzip2 > notmuch-`git show-ref --hash=8 HEAD`.tar.bz2
28 #
29 Source0:        notmuch-%{git}.tar.bz2
30 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
31
32 BuildRequires:  xapian-core-devel
33 BuildRequires:  gmime-devel
34 BuildRequires:  libtalloc-devel
35 BuildRequires:  zlib-devel
36 BuildRequires:  emacs-el
37 BuildRequires:  emacs-nox
38
39 Requires:       emacs(bin) >= %{emacs_version}
40
41 %description
42 * "Not much mail" is what Notmuch thinks about your email
43   collection. Even if you receive 12000 messages per month or have on
44   the order of millions of messages that you've been saving for
45   decades. Regardless, Notmuch will be able to quickly search all of
46   it. It's just plain not much mail.
47
48 * "Not much mail" is also what you should have in your inbox at any
49   time. Notmuch gives you what you need, (tags and fast search), so
50   that you can keep your inbox tamed and focus on what really matters
51   in your life, (which is surely not email).
52
53 * Notmuch is an answer to Sup. Sup is a very good email program
54   written by William Morgan (and others) and is the direct inspiration
55   for Notmuch. Notmuch began as an effort to rewrite
56   performance-critical pieces of Sup in C rather than ruby. From
57   there, it grew into a separate project. One significant contribution
58   Notmuch makes compared to Sup is the separation of the
59   indexer/searcher from the user interface. (Notmuch provides a
60   library interface so that its indexing/searching/tagging features
61   can be integrated into any email program.)
62
63 * Notmuch is not much of an email program. It doesn't receive messages
64   (no POP or IMAP suport). It doesn't send messages (no mail composer,
65   no network code at all). And for what it does do (email search) that
66   work is provided by an external library, Xapian. So if Notmuch
67   provides no user interface and Xapian does all the heavy lifting,
68   then what's left here? Not much.
69
70 Notmuch is still in the early stages of development, but it does
71 include one user interface, (implemented within emacs), which has at
72 least two users using it for reading all of their incoming mail. If
73 you've been looking for a fast, global-search and tag-based email
74 reader to use within emacs, then Notmuch may be exactly what you've
75 been looking for.
76
77 Otherwise, if you're a developer of an existing email program and
78 would love a good library interface for fast, global search with
79 support for arbitrary tags, then Notmuch also may be exactly what
80 you've been looking for.
81
82 %prep
83 %setup -q -n notmuch
84
85 %build
86 make %{?_smp_mflags} CFLAGS="%{optflags}"
87 emacs -batch -f batch-byte-compile notmuch.el
88
89 %install
90 rm -rf %{buildroot}
91 make install DESTDIR=%{buildroot} prefix=%{_prefix}
92 mkdir -p %{buildroot}%{emacs_startdir}
93 install -m0644 -p notmuch.el* %{buildroot}%{emacs_startdir}
94
95 %clean
96 rm -rf %{buildroot}
97
98 %files
99 %defattr(-,root,root,-)
100 %doc AUTHORS COPYING COPYING-GPL-3 INSTALL README TODO
101
102 %{_sysconfdir}/bash_completion.d/notmuch
103 %{_bindir}/notmuch
104 %{_mandir}/man1/notmuch.1*
105 %{emacs_startdir}/notmuch.el*
106
107 %changelog
108 * Wed Nov 18 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.0-0.3.306635c2
109 - First version
110