]> git.notmuchmail.org Git - notmuch/blob - packaging/fedora/notmuch.spec
packaging: fedora: update
[notmuch] / packaging / fedora / notmuch.spec
1 %global git 6b9a717c
2 %global date %(date +%Y%m%d)
3
4 %if %($(pkg-config emacs) ; echo $?)
5 %global emacs_version 23.1
6 %global emacs_lispdir %{_datadir}/emacs/site-lisp
7 %global emacs_startdir %{_datadir}/emacs/site-lisp/site-start.d
8 %else
9 %global emacs_version %(pkg-config emacs --modversion)
10 %global emacs_lispdir %(pkg-config emacs --variable sitepkglispdir)
11 %global emacs_startdir %(pkg-config emacs --variable sitestartdir)
12 %endif
13
14 # If you are doing a git snapshot:
15 #
16 # Release should be 1%{git}%{?dist}
17 # Source0 should be notmuch-%{version}-%{git}.tar.gz
18 # git version is generated by 'git show-ref --hash=8 HEAD'
19 #
20 # To create a tarball:
21 #
22 # git clone git://notmuchmail.org/git/notmuch
23 # cd notmuch
24 # git archive --format=tar --prefix=notmuch-0.4/ HEAD | gzip > notmuch-0.4-`git show-ref --hash=8 HEAD`.tar.gz
25 #
26
27 Name:           notmuch
28 Version:        0.15.2
29 Release:        1%{?dist}
30 Summary:        Not much of an email program
31
32 Group:          Applications/Internet
33 License:        GPLv3+
34 URL:            http://notmuchmail.org/
35
36 Source0:        http://notmuchmail.org/releases/notmuch-%{version}.tar.gz
37 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
38
39 BuildRequires:  xapian-core-devel
40 BuildRequires:  gmime-devel
41 BuildRequires:  libtalloc-devel
42 BuildRequires:  zlib-devel
43 BuildRequires:  emacs-el
44 BuildRequires:  emacs-nox
45
46 Requires:       emacs(bin) >= %{emacs_version}
47
48 %description
49 * "Not much mail" is what Notmuch thinks about your email
50   collection. Even if you receive 12000 messages per month or have on
51   the order of millions of messages that you've been saving for
52   decades. Regardless, Notmuch will be able to quickly search all of
53   it. It's just plain not much mail.
54
55 * "Not much mail" is also what you should have in your inbox at any
56   time. Notmuch gives you what you need, (tags and fast search), so
57   that you can keep your inbox tamed and focus on what really matters
58   in your life, (which is surely not email).
59
60 * Notmuch is an answer to Sup. Sup is a very good email program
61   written by William Morgan (and others) and is the direct inspiration
62   for Notmuch. Notmuch began as an effort to rewrite
63   performance-critical pieces of Sup in C rather than ruby. From
64   there, it grew into a separate project. One significant contribution
65   Notmuch makes compared to Sup is the separation of the
66   indexer/searcher from the user interface. (Notmuch provides a
67   library interface so that its indexing/searching/tagging features
68   can be integrated into any email program.)
69
70 * Notmuch is not much of an email program. It doesn't receive messages
71   (no POP or IMAP support). It doesn't send messages (no mail composer,
72   no network code at all). And for what it does do (email search) that
73   work is provided by an external library, Xapian. So if Notmuch
74   provides no user interface and Xapian does all the heavy lifting,
75   then what's left here? Not much.
76
77 Notmuch is still in the early stages of development, but it does
78 include one user interface, (implemented within Emacs), which has at
79 least two users using it for reading all of their incoming mail. If
80 you've been looking for a fast, global-search and tag-based email
81 reader to use within Emacs, then Notmuch may be exactly what you've
82 been looking for.
83
84 Otherwise, if you're a developer of an existing email program and
85 would love a good library interface for fast, global search with
86 support for arbitrary tags, then Notmuch also may be exactly what
87 you've been looking for.
88
89 %package        devel
90 Summary:        Development files for %{name}
91 Group:          Development/Libraries
92 Requires:       %{name} = %{version}-%{release}
93
94 %description    devel
95 The %{name}-devel package contains libraries and header files for
96 developing applications that use %{name}.
97
98 %prep
99 %setup -q
100
101 %build
102 ./configure --prefix=%{_prefix} --libdir=%{_libdir} --sysconfdir=%{_sysconfdir} \
103     --mandir=%{_mandir} --includedir=%{_includedir} --emacslispdir=%{_emacs_sitelispdir}
104 make %{?_smp_mflags} CFLAGS="%{optflags}"
105
106 %install
107 make install DESTDIR=%{buildroot}
108
109 %clean
110 rm -rf %{buildroot}
111
112 %post -p /sbin/ldconfig
113
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(-,root,root,-)
118 %doc AUTHORS COPYING COPYING-GPL-3 INSTALL README
119
120 %{_bindir}/notmuch
121 %{_libdir}/libnotmuch.so.3*
122 %{_mandir}/man?/*
123
124 %{_emacs_sitelispdir}/*
125
126 %{_datarootdir}/zsh/functions/Completion/Unix/_notmuch
127 %{_sysconfdir}/bash_completion.d/notmuch
128
129 %files devel
130 %defattr(-,root,root,-)
131 %doc AUTHORS COPYING COPYING-GPL-3 INSTALL README
132 %{_includedir}/*
133 %{_libdir}/*.so
134
135
136 %changelog
137 * Sun Apr 28 2013 Felipe Contreras <felipe.contreras@gmail.com> - 0.15.2-1
138 - Update to latest upstream
139
140 * Tue Nov  2 2010 Scott Henson <shenson@redhat.com> - 0.4-1
141 - New upstream release
142
143 * Wed Nov 18 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.0-0.3.306635c2
144 - First version
145