]> git.notmuchmail.org Git - notmuch/blob - packaging/fedora/notmuch.spec
emacs: Add new option notmuch-search-hide-excluded
[notmuch] / packaging / fedora / notmuch.spec
1 %global git 6b9a717c
2 %global date %(date +%Y%m%d)
3
4 # If you are doing a git snapshot:
5 #
6 # Release should be 1%{git}%{?dist}
7 # Source0 should be notmuch-%{version}-%{git}.tar.gz
8 # git version is generated by 'git show-ref --hash=8 HEAD'
9 #
10 # To create a tarball:
11 #
12 # git clone git://notmuchmail.org/git/notmuch
13 # cd notmuch
14 # git archive --format=tar --prefix=notmuch-0.4/ HEAD | gzip > notmuch-0.4-`git show-ref --hash=8 HEAD`.tar.gz
15 #
16
17 Name:           notmuch
18 Version:        0.15.2
19 Release:        3%{?dist}
20 Summary:        Thread-based email index, search and tagging
21
22 Group:          Applications/Internet
23 License:        GPLv3+
24 URL:            https://notmuchmail.org/
25
26 Source0:        https://notmuchmail.org/releases/notmuch-%{version}.tar.gz
27
28 BuildRequires:  xapian-core-devel gmime-devel libtalloc-devel
29 BuildRequires:  zlib-devel emacs-el emacs-nox python ruby ruby-devel perl
30
31 %description
32 Fast system for indexing, searching, and tagging email.  Even if you
33 receive 12000 messages per month or have on the order of millions of
34 messages that you've been saving for decades, Notmuch will be able to
35 quickly search all of it.
36
37 Notmuch is not much of an email program. It doesn't receive messages
38 (no POP or IMAP support). It doesn't send messages (no mail composer,
39 no network code at all). And for what it does do (email search) that
40 work is provided by an external library, Xapian. So if Notmuch
41 provides no user interface and Xapian does all the heavy lifting, then
42 what's left here? Not much.
43
44 %package devel
45 Summary:        Development libraries and header files for %{name}
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48
49 %description devel
50 The %{name}-devel package contains libraries and header files for
51 developing applications that use %{name}.
52
53 %package -n emacs-notmuch
54 Summary:        Not much support for Emacs
55 Group:          Applications/Editors
56 BuildArch:      noarch
57 Requires:       %{name} = %{version}-%{release}, emacs(bin) >= %{_emacs_version}
58
59 %description -n emacs-notmuch
60 %{summary}.
61
62 %package -n python-notmuch
63 Summary:        Python bindings for notmuch
64 Group:          Development/Libraries
65 BuildArch:      noarch
66 Requires:       %{name} = %{version}-%{release}
67
68 %description -n python-notmuch
69 %{summary}.
70
71 %package -n notmuch-ruby
72 Summary:        Ruby bindings for notmuch
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75
76 %description -n notmuch-ruby
77 %{summary}.
78
79 %package mutt
80 Summary:        Notmuch (of a) helper for Mutt
81 Group:          Development/Libraries
82 BuildArch:      noarch
83 Requires:       %{name} = %{version}-%{release}
84 Requires:       perl(Term::ReadLine::Gnu)
85
86 %description mutt
87 notmuch-mutt provide integration among the Mutt mail user agent and
88 the Notmuch mail indexer.
89
90 %prep
91 %setup -q
92
93 %build
94 ./configure --prefix=%{_prefix} --libdir=%{_libdir} --sysconfdir=%{_sysconfdir} \
95     --mandir=%{_mandir} --includedir=%{_includedir} --emacslispdir=%{_emacs_sitelispdir}
96 make %{?_smp_mflags} CFLAGS="%{optflags}"
97
98 pushd bindings/python
99     python setup.py build
100 popd
101
102 pushd bindings/ruby
103     export CONFIGURE_ARGS="--with-cflags='%{optflags}'"
104     ruby extconf.rb --vendor
105     make
106 popd
107
108 pushd contrib/notmuch-mutt
109     make
110 popd
111
112 %install
113 make install DESTDIR=%{buildroot}
114
115 pushd bindings/python
116     python setup.py install -O1 --skip-build --root %{buildroot}
117 popd
118
119 pushd bindings/ruby
120     make install DESTDIR=%{buildroot}
121 popd
122
123 install contrib/notmuch-mutt/notmuch-mutt %{buildroot}%{_bindir}/notmuch-mutt
124 install contrib/notmuch-mutt/notmuch-mutt.1 %{buildroot}%{_mandir}/man1/notmuch-mutt.1
125
126 %post -p /sbin/ldconfig
127
128 %postun -p /sbin/ldconfig
129
130 %files
131 %doc AUTHORS COPYING COPYING-GPL-3 INSTALL README
132 %{_sysconfdir}/bash_completion.d/notmuch
133 %{_datadir}/zsh/functions/Completion/Unix/_notmuch
134 %{_bindir}/notmuch
135 %{_mandir}/man?/*
136 %{_libdir}/libnotmuch.so.3*
137
138 %files devel
139 %{_libdir}/libnotmuch.so
140 %{_includedir}/*
141
142 %files -n emacs-notmuch
143 %{_emacs_sitelispdir}/*
144
145 %files -n python-notmuch
146 %doc bindings/python/README
147 %{python_sitelib}/*
148
149 %files -n notmuch-ruby
150 %{ruby_vendorarchdir}/*
151
152 %files mutt
153 %{_bindir}/notmuch-mutt
154 %{_mandir}/man1/notmuch-mutt.1*
155
156 %changelog
157 * Sun Apr 28 2013 Felipe Contreras <felipe.contreras@gmail.com> - 0.15.2-3
158 - Add ruby bingings
159
160 * Sun Apr 28 2013 Felipe Contreras <felipe.contreras@gmail.com> - 0.15.2-2
161 - Sync with Fedora
162
163 * Sun Apr 28 2013 Felipe Contreras <felipe.contreras@gmail.com> - 0.15.2-1
164 - Update to latest upstream
165
166 * Tue Nov  2 2010 Scott Henson <shenson@redhat.com> - 0.4-1
167 - New upstream release
168
169 * Wed Nov 18 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.0-0.3.306635c2
170 - First version
171