]> git.notmuchmail.org Git - notmuch/blob - packaging/fedora/notmuch.spec
packaging: fedora: separate package for emacs
[notmuch] / packaging / fedora / notmuch.spec
1 %global git 6b9a717c
2 %global date %(date +%Y%m%d)
3
4 # If you are doing a git snapshot:
5 #
6 # Release should be 1%{git}%{?dist}
7 # Source0 should be notmuch-%{version}-%{git}.tar.gz
8 # git version is generated by 'git show-ref --hash=8 HEAD'
9 #
10 # To create a tarball:
11 #
12 # git clone git://notmuchmail.org/git/notmuch
13 # cd notmuch
14 # git archive --format=tar --prefix=notmuch-0.4/ HEAD | gzip > notmuch-0.4-`git show-ref --hash=8 HEAD`.tar.gz
15 #
16
17 Name:           notmuch
18 Version:        0.15.2
19 Release:        1%{?dist}
20 Summary:        Thread-based email index, search and tagging
21
22 Group:          Applications/Internet
23 License:        GPLv3+
24 URL:            http://notmuchmail.org/
25
26 Source0:        http://notmuchmail.org/releases/notmuch-%{version}.tar.gz
27
28 BuildRequires:  xapian-core-devel gmime-devel libtalloc-devel
29 BuildRequires:  zlib-devel emacs-el emacs-nox
30
31 %description
32 Fast system for indexing, searching, and tagging email.  Even if you
33 receive 12000 messages per month or have on the order of millions of
34 messages that you've been saving for decades, Notmuch will be able to
35 quickly search all of it.
36
37 Notmuch is not much of an email program. It doesn't receive messages
38 (no POP or IMAP support). It doesn't send messages (no mail composer,
39 no network code at all). And for what it does do (email search) that
40 work is provided by an external library, Xapian. So if Notmuch
41 provides no user interface and Xapian does all the heavy lifting, then
42 what's left here? Not much.
43
44 %package devel
45 Summary:        Development libraries and header files for %{name}
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48
49 %description devel
50 The %{name}-devel package contains libraries and header files for
51 developing applications that use %{name}.
52
53 %package -n emacs-notmuch
54 Summary:        Not much support for Emacs
55 Group:          Applications/Editors
56 BuildArch:      noarch
57 Requires:       %{name} = %{version}-%{release}, emacs(bin) >= %{_emacs_version}
58
59 %description -n emacs-notmuch
60 %{summary}.
61
62 %prep
63 %setup -q
64
65 %build
66 ./configure --prefix=%{_prefix} --libdir=%{_libdir} --sysconfdir=%{_sysconfdir} \
67     --mandir=%{_mandir} --includedir=%{_includedir} --emacslispdir=%{_emacs_sitelispdir}
68 make %{?_smp_mflags} CFLAGS="%{optflags}"
69
70 %install
71 make install DESTDIR=%{buildroot}
72
73 %post -p /sbin/ldconfig
74
75 %postun -p /sbin/ldconfig
76
77 %files
78 %doc AUTHORS COPYING COPYING-GPL-3 INSTALL README
79 %{_sysconfdir}/bash_completion.d/notmuch
80 %{_datadir}/zsh/functions/Completion/Unix/_notmuch
81 %{_bindir}/notmuch
82 %{_mandir}/man?/*
83 %{_libdir}/libnotmuch.so.3*
84
85 %files devel
86 %{_libdir}/libnotmuch.so
87 %{_includedir}/*
88
89 %files -n emacs-notmuch
90 %{_emacs_sitelispdir}/*
91
92 %changelog
93 * Sun Apr 28 2013 Felipe Contreras <felipe.contreras@gmail.com> - 0.15.2-1
94 - Update to latest upstream
95
96 * Tue Nov  2 2010 Scott Henson <shenson@redhat.com> - 0.4-1
97 - New upstream release
98
99 * Wed Nov 18 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.0-0.3.306635c2
100 - First version
101