]> git.notmuchmail.org Git - notmuch/blobdiff - bindings/python/setup.py
py3k: The execfile built-in has been removed in python 3
[notmuch] / bindings / python / setup.py
index 286fd1962187b6351036d54d547e69dd9c0b1016..2e58dab1d6a6cc3a6193031f2410b082e385b9eb 100644 (file)
@@ -7,7 +7,7 @@ from distutils.core import setup
 # get the notmuch version number without importing the notmuch module
 version_file = os.path.join(os.path.dirname(os.path.abspath(__file__)),
                             'notmuch', 'version.py')
-execfile(version_file)
+exec(compile(open(version_file).read(), version_file, 'exec'))
 assert __VERSION__, 'Failed to read the notmuch binding version number'
 
 setup(name='notmuch',