]> git.notmuchmail.org Git - notmuch/blobdiff - bindings/python/setup.py
Revert "python: Simplify setup.py"
[notmuch] / bindings / python / setup.py
index 7a4b43f5fa5409cb35cbaea69624d2b46bbc9cbb..1497bc4372df5ac9f99ded5d06a8b5bf6b8b40a2 100644 (file)
@@ -1,14 +1,29 @@
 #!/usr/bin/env python
 
+import os
+import re
 from distutils.core import setup
-from notmuch import __VERSION__
+
+def get_version():
+    file = open('notmuch/__init__.py')
+    try:
+        for line in file:
+            if re.match('__VERSION__\s*=\s*',line) != None:
+                version = line.split('=', 1)[1]
+                return eval(version, {}, {})
+    finally:
+        file.close()
+    raise IOError('Unexpected end-of-file')
+
+__VERSION__=get_version()
+
 setup(name='notmuch',
       version=__VERSION__,
       description='Python binding of the notmuch mail search and indexing library.',
       author='Sebastian Spaeth',
       author_email='Sebastian@SSpaeth.de',
-      url='http://bitbucket.org/spaetz/cnotmuch/',
-      download_url='http://bitbucket.org/spaetz/cnotmuch/get/v'+__VERSION__+'.tar.gz',
+      url='http://notmuchmail.org/',
+      download_url='http://notmuchmail.org/releases/notmuch-'+__VERSION__+'.tar.gz',
       packages=['notmuch'],
       keywords = ["library", "email"],
       long_description="""Overview
@@ -16,20 +31,21 @@ setup(name='notmuch',
 
 The notmuch  module provides an interface to the `notmuch <http://notmuchmail.org>`_ functionality, directly interfacing with a shared notmuch library. Notmuch provides a maildatabase that allows for extremely quick searching and filtering of your email according to various criteria.
 
-The documentation for the latest cnotmuch release can be `viewed online <http://packages.python.org/cnotmuch>`_.
+The documentation for the latest cnotmuch release can be `viewed online <http://packages.python.org/notmuch>`_.
 
 The classes notmuch.Database, notmuch.Query  provide most of the core functionality, returning notmuch.Messages and notmuch.Tags.
 
 Installation and Deinstallation
 -------------------------------
 
-cnotmuch is packaged on http://pypi.python.org. This means you can do
-"easy_install cnotmuch" (or using pip) on your linux box and it will
-get installed into:
+notmuch is included in the upstream notmuch source repository and it is
+packaged on http://pypi.python.org. This means you can do "easy_install
+notmuch" (or using pip) on your linux box and it will get installed
+into:
 
 /usr/local/lib/python2.x/dist-packages/
 
-For uninstalling, you will need to remove the "cnotmuch-0.1-py2.x.egg"
+For uninstalling, you will need to remove the "notmuch-0.x-py2.x.egg"
 directory and delete one entry refering to cnotmuch in the
 "easy-install.pth" file in that directory. There should be no trace
 left of cnotmuch then.
@@ -37,7 +53,10 @@ left of cnotmuch then.
 Requirements
 ------------
 
-You need to have notmuch installed (or rather libnotmuch.so.1). The release version 0.1 should work fine. Also, cnotmuch makes use of the ctypes library, and has only been tested with python 2.5. It will not work on earlier python versions.
+You need to have notmuch installed (or rather libnotmuch.so.1). The
+release version 0.3 should work fine. Also, notmuch makes use of the
+ctypes library, and has only been tested with python 2.5. It will not
+work on earlier python versions.
 """,
       classifiers=['Development Status :: 2 - Pre-Alpha',
                    'Intended Audience :: Developers',