]> git.notmuchmail.org Git - notmuch/blobdiff - debian/rules
debian: Add package for debugging symbols (Closes: #717339)
[notmuch] / debian / rules
index 169a805021a5f71acd7e7dd836f5dc7d9e12d2bf..7a19445e93a2a3f1882c4f339bc525643fa2b126 100755 (executable)
@@ -1,24 +1,32 @@
 #!/usr/bin/make -f
 
-VERSION=$(shell dpkg-parsechangelog | sed -n 's/^Version:\([^-]*\)/\1/p')
+python3_all = py3versions -s | xargs -n1 | xargs -t -I {} env {}
 
 %:
-       dh --with python2 $@
+       dh $@ --with python2,python3
 
 override_dh_auto_configure:
-       cp version debian/version.pre-build
-       echo $(VERSION) > version
        dh_auto_configure -- --emacslispdir=/usr/share/emacs/site-lisp/notmuch
 
 override_dh_auto_build:
-       dh_auto_build
+       dh_auto_build -- V=1
        dh_auto_build --sourcedirectory bindings/python
+       cd bindings/python && $(python3_all) setup.py build
+       cd bindings/ruby && ruby extconf.rb --vendor && make
+       $(MAKE) -C contrib/notmuch-mutt
 
 override_dh_auto_clean:
-       -mv debian/version.pre-build version
        dh_auto_clean
        dh_auto_clean --sourcedirectory bindings/python
+       cd bindings/python && $(python3_all) setup.py clean -a
+       dh_auto_clean --sourcedirectory bindings/ruby
+       $(MAKE) -C contrib/notmuch-mutt clean
 
 override_dh_auto_install:
        dh_auto_install
        dh_auto_install --sourcedirectory bindings/python
+       cd bindings/python && $(python3_all) setup.py install --install-layout=deb --root=$(CURDIR)/debian/tmp
+       dh_auto_install --sourcedirectory bindings/ruby
+
+override_dh_strip:
+       dh_strip --dbg-package notmuch-dbg