]> git.notmuchmail.org Git - notmuch/blobdiff - debian/rules
debian: Add package for debugging symbols (Closes: #717339)
[notmuch] / debian / rules
index 71a5602844a46dd45ed1fed1c5cd51975e472883..7a19445e93a2a3f1882c4f339bc525643fa2b126 100755 (executable)
@@ -9,7 +9,7 @@ override_dh_auto_configure:
        dh_auto_configure -- --emacslispdir=/usr/share/emacs/site-lisp/notmuch
 
 override_dh_auto_build:
-       dh_auto_build
+       dh_auto_build -- V=1
        dh_auto_build --sourcedirectory bindings/python
        cd bindings/python && $(python3_all) setup.py build
        cd bindings/ruby && ruby extconf.rb --vendor && make
@@ -27,3 +27,6 @@ override_dh_auto_install:
        dh_auto_install --sourcedirectory bindings/python
        cd bindings/python && $(python3_all) setup.py install --install-layout=deb --root=$(CURDIR)/debian/tmp
        dh_auto_install --sourcedirectory bindings/ruby
+
+override_dh_strip:
+       dh_strip --dbg-package notmuch-dbg