]> git.notmuchmail.org Git - notmuch/blobdiff - debian/rules
Merge tag 'debian/0.17-3'
[notmuch] / debian / rules
index cbe925d7587131c8ec8761915930894c60c096fd..7a19445e93a2a3f1882c4f339bc525643fa2b126 100755 (executable)
@@ -1,3 +1,32 @@
 #!/usr/bin/make -f
+
+python3_all = py3versions -s | xargs -n1 | xargs -t -I {} env {}
+
 %:
-       dh $@
+       dh $@ --with python2,python3
+
+override_dh_auto_configure:
+       dh_auto_configure -- --emacslispdir=/usr/share/emacs/site-lisp/notmuch
+
+override_dh_auto_build:
+       dh_auto_build -- V=1
+       dh_auto_build --sourcedirectory bindings/python
+       cd bindings/python && $(python3_all) setup.py build
+       cd bindings/ruby && ruby extconf.rb --vendor && make
+       $(MAKE) -C contrib/notmuch-mutt
+
+override_dh_auto_clean:
+       dh_auto_clean
+       dh_auto_clean --sourcedirectory bindings/python
+       cd bindings/python && $(python3_all) setup.py clean -a
+       dh_auto_clean --sourcedirectory bindings/ruby
+       $(MAKE) -C contrib/notmuch-mutt clean
+
+override_dh_auto_install:
+       dh_auto_install
+       dh_auto_install --sourcedirectory bindings/python
+       cd bindings/python && $(python3_all) setup.py install --install-layout=deb --root=$(CURDIR)/debian/tmp
+       dh_auto_install --sourcedirectory bindings/ruby
+
+override_dh_strip:
+       dh_strip --dbg-package notmuch-dbg