]> git.notmuchmail.org Git - notmuch/blobdiff - debian/rules
Merge tag 'debian/0.29.2-2'
[notmuch] / debian / rules
index 15710a895946b79e59bd7c24fba27ea12dbdf65a..bf9d0bbdc7379ca39e25a436127cee91f06e551e 100755 (executable)
@@ -1,38 +1,35 @@
 #!/usr/bin/make -f
 
-python3_all = py3versions -s | xargs -n1 | xargs -t -I {} env {}
+export PYBUILD_NAME=notmuch
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
 %:
-       dh $@ --with python2,python3,elpa
+       dh $@ --with python3,elpa
 
 override_dh_auto_configure:
-       ./configure --prefix=/usr \
+       BASHCMD=/bin/bash ./configure --prefix=/usr \
                --libdir=/usr/lib/$$(dpkg-architecture -q DEB_TARGET_MULTIARCH) \
                --includedir=/usr/include \
                --mandir=/usr/share/man \
                --infodir=/usr/share/info \
                --sysconfdir=/etc \
-               --localstatedir=/var \
-               --emacslispdir=/usr/share/emacs/site-lisp/notmuch
+               --zshcompletiondir=/usr/share/zsh/vendor-completions \
+               --localstatedir=/var
 
 override_dh_auto_build:
        dh_auto_build -- V=1
-       dh_auto_build --sourcedirectory bindings/python
-       cd bindings/python && $(python3_all) setup.py build
+       dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python
        $(MAKE) -C contrib/notmuch-mutt
 
 override_dh_auto_clean:
        dh_auto_clean
-       dh_auto_clean --sourcedirectory bindings/python
-       cd bindings/python && $(python3_all) setup.py clean -a
+       dh_auto_clean --buildsystem=pybuild --sourcedirectory bindings/python
        dh_auto_clean --sourcedirectory bindings/ruby
        $(MAKE) -C contrib/notmuch-mutt clean
 
 override_dh_auto_install:
        dh_auto_install
-       dh_auto_install --sourcedirectory bindings/python
-       cd bindings/python && $(python3_all) setup.py install --install-layout=deb --root=$(CURDIR)/debian/tmp
+       dh_auto_install --buildsystem=pybuild --sourcedirectory bindings/python
+       $(MAKE) -C contrib/notmuch-mutt DESTDIR=$(CURDIR)/debian/tmp install
        dh_auto_install --sourcedirectory bindings/ruby
-
-override_dh_strip:
-       dh_strip --dbg-package notmuch-dbg