]> git.notmuchmail.org Git - notmuch/blobdiff - debian/rules
Merge tag 'debian/0.29.2-2'
[notmuch] / debian / rules
index ebd1048170839dfc90aa75c789b1669af252bee2..bf9d0bbdc7379ca39e25a436127cee91f06e551e 100755 (executable)
@@ -1,11 +1,11 @@
 #!/usr/bin/make -f
 
 #!/usr/bin/make -f
 
-python3_all = py3versions -s | xargs -n1 | xargs -t -I {} env {}
+export PYBUILD_NAME=notmuch
 
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
 %:
 
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
 %:
-       dh $@ --with python2,python3,elpa
+       dh $@ --with python3,elpa
 
 override_dh_auto_configure:
        BASHCMD=/bin/bash ./configure --prefix=/usr \
 
 override_dh_auto_configure:
        BASHCMD=/bin/bash ./configure --prefix=/usr \
@@ -19,20 +19,17 @@ override_dh_auto_configure:
 
 override_dh_auto_build:
        dh_auto_build -- V=1
 
 override_dh_auto_build:
        dh_auto_build -- V=1
-       dh_auto_build --sourcedirectory bindings/python
-       cd bindings/python && $(python3_all) setup.py build
+       dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python
        $(MAKE) -C contrib/notmuch-mutt
 
 override_dh_auto_clean:
        dh_auto_clean
        $(MAKE) -C contrib/notmuch-mutt
 
 override_dh_auto_clean:
        dh_auto_clean
-       dh_auto_clean --sourcedirectory bindings/python
-       cd bindings/python && $(python3_all) setup.py clean -a
+       dh_auto_clean --buildsystem=pybuild --sourcedirectory bindings/python
        dh_auto_clean --sourcedirectory bindings/ruby
        $(MAKE) -C contrib/notmuch-mutt clean
 
 override_dh_auto_install:
        dh_auto_install
        dh_auto_clean --sourcedirectory bindings/ruby
        $(MAKE) -C contrib/notmuch-mutt clean
 
 override_dh_auto_install:
        dh_auto_install
-       dh_auto_install --sourcedirectory bindings/python
-       cd bindings/python && $(python3_all) setup.py install --install-layout=deb --root=$(CURDIR)/debian/tmp
+       dh_auto_install --buildsystem=pybuild --sourcedirectory bindings/python
        $(MAKE) -C contrib/notmuch-mutt DESTDIR=$(CURDIR)/debian/tmp install
        dh_auto_install --sourcedirectory bindings/ruby
        $(MAKE) -C contrib/notmuch-mutt DESTDIR=$(CURDIR)/debian/tmp install
        dh_auto_install --sourcedirectory bindings/ruby