]> git.notmuchmail.org Git - notmuch/blobdiff - packaging/fedora/notmuch.spec
Update of the spec file to the 0.4 release.
[notmuch] / packaging / fedora / notmuch.spec
index cca3a1bb435e74ec4710ed7e70886a0bfd621c8a..ef1af2e464d3a217e931334095f2b46bc149a772 100644 (file)
@@ -1,4 +1,5 @@
-%global git 306635c2
+%global git 6b9a717c
+%global date %(date +%Y%m%d)
 
 %if %($(pkg-config emacs) ; echo $?)
 %global emacs_version 23.1
 
 %if %($(pkg-config emacs) ; echo $?)
 %global emacs_version 23.1
 %global emacs_startdir %(pkg-config emacs --variable sitestartdir)
 %endif
 
 %global emacs_startdir %(pkg-config emacs --variable sitestartdir)
 %endif
 
+# If you are doing a git snapshot:
+#
+# Release should be 1%{git}%{?dist}
+# Source0 should be notmuch-%{version}-%{git}.tar.gz
+# git version is generated by 'git show-ref --hash=8 HEAD'
+#
+# To create a tarball:
+#
+# git clone git://notmuchmail.org/git/notmuch
+# cd notmuch
+# git archive --format=tar --prefix=notmuch-0.4/ HEAD | gzip > notmuch-0.4-`git show-ref --hash=8 HEAD`.tar.gz
+#
+
 Name:           notmuch
 Name:           notmuch
-Version:        0.0
-Release:        0.3.%{git}%{?dist}
+Version:        0.4
+Release:        1%{?dist}
 Summary:        Not much of an email program
 
 Group:          Applications/Internet
 License:        GPLv3+
 URL:            http://notmuchmail.org/
 
 Summary:        Not much of an email program
 
 Group:          Applications/Internet
 License:        GPLv3+
 URL:            http://notmuchmail.org/
 
-#
-# To create a tarball:
-#
-# git clone git://notmuchmail.org/git/notmuch
-# cd notmuch
-# git archive --format=tar --prefix=notmuch/ HEAD | bzip2 > notmuch-`git show-ref --hash=8 HEAD`.tar.bz2
-#
-Source0:        notmuch-%{git}.tar.bz2
+Source0:        http://notmuchmail.org/releases/notmuch-%{version}.tar.gz
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
 BuildRequires:  xapian-core-devel
 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
 BuildRequires:  xapian-core-devel
@@ -61,17 +68,17 @@ Requires:       emacs(bin) >= %{emacs_version}
   can be integrated into any email program.)
 
 * Notmuch is not much of an email program. It doesn't receive messages
   can be integrated into any email program.)
 
 * Notmuch is not much of an email program. It doesn't receive messages
-  (no POP or IMAP suport). It doesn't send messages (no mail composer,
+  (no POP or IMAP support). It doesn't send messages (no mail composer,
   no network code at all). And for what it does do (email search) that
   work is provided by an external library, Xapian. So if Notmuch
   provides no user interface and Xapian does all the heavy lifting,
   then what's left here? Not much.
 
 Notmuch is still in the early stages of development, but it does
   no network code at all). And for what it does do (email search) that
   work is provided by an external library, Xapian. So if Notmuch
   provides no user interface and Xapian does all the heavy lifting,
   then what's left here? Not much.
 
 Notmuch is still in the early stages of development, but it does
-include one user interface, (implemented within emacs), which has at
+include one user interface, (implemented within Emacs), which has at
 least two users using it for reading all of their incoming mail. If
 you've been looking for a fast, global-search and tag-based email
 least two users using it for reading all of their incoming mail. If
 you've been looking for a fast, global-search and tag-based email
-reader to use within emacs, then Notmuch may be exactly what you've
+reader to use within Emacs, then Notmuch may be exactly what you've
 been looking for.
 
 Otherwise, if you're a developer of an existing email program and
 been looking for.
 
 Otherwise, if you're a developer of an existing email program and
@@ -79,32 +86,59 @@ would love a good library interface for fast, global search with
 support for arbitrary tags, then Notmuch also may be exactly what
 you've been looking for.
 
 support for arbitrary tags, then Notmuch also may be exactly what
 you've been looking for.
 
+%package        devel
+Summary:        Development files for %{name}
+Group:          Development/Libraries
+Requires:       %{name} = %{version}-%{release}
+
+%description    devel
+The %{name}-devel package contains libraries and header files for
+developing applications that use %{name}.
+
 %prep
 %prep
-%setup -q -n notmuch
+%setup -q
 
 %build
 
 %build
+./configure --prefix=/usr --libdir=%{_libdir} --sysconfdir=%{_sysconfdir}
 make %{?_smp_mflags} CFLAGS="%{optflags}"
 make %{?_smp_mflags} CFLAGS="%{optflags}"
-emacs -batch -f batch-byte-compile notmuch.el
+emacs -batch -f batch-byte-compile emacs/*.el
 
 %install
 rm -rf %{buildroot}
 make install DESTDIR=%{buildroot} prefix=%{_prefix}
 
 %install
 rm -rf %{buildroot}
 make install DESTDIR=%{buildroot} prefix=%{_prefix}
-mkdir -p %{buildroot}%{emacs_startdir}
-install -m0644 -p notmuch.el* %{buildroot}%{emacs_startdir}
+mv %{buildroot}%{_sysconfdir}/bash_completion.d %{buildroot}%{_datarootdir}/bash_completion
 
 %clean
 rm -rf %{buildroot}
 
 
 %clean
 rm -rf %{buildroot}
 
+%post -p /sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
 %files
 %defattr(-,root,root,-)
 %doc AUTHORS COPYING COPYING-GPL-3 INSTALL README TODO
 
 %files
 %defattr(-,root,root,-)
 %doc AUTHORS COPYING COPYING-GPL-3 INSTALL README TODO
 
-%{_sysconfdir}/bash_completion.d/notmuch
 %{_bindir}/notmuch
 %{_bindir}/notmuch
+%{_libdir}/libnotmuch.so.*
 %{_mandir}/man1/notmuch.1*
 %{_mandir}/man1/notmuch.1*
-%{emacs_startdir}/notmuch.el*
+
+%{_emacs_sitelispdir}/*
+
+%{_datarootdir}/zsh/functions/Completion/Unix/notmuch
+%{_datarootdir}/bash_completion/notmuch
+
+%files devel
+%defattr(-,root,root,-)
+%doc AUTHORS COPYING COPYING-GPL-3 INSTALL README TODO
+%{_includedir}/*
+%{_libdir}/*.so
+
 
 %changelog
 
 %changelog
+* Tue Nov  2 2010 Scott Henson <shenson@redhat.com> - 0.4-1
+- New upstream release
+
 * Wed Nov 18 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.0-0.3.306635c2
 - First version
 
 * Wed Nov 18 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.0-0.3.306635c2
 - First version