]> git.notmuchmail.org Git - notmuch/blobdiff - debian/rules
Merge tag 'debian/0.28-2' into debian/stretch-backports
[notmuch] / debian / rules
index 15710a895946b79e59bd7c24fba27ea12dbdf65a..4979ec3f659c4317c766312aee6c1a75f350e770 100755 (executable)
@@ -2,18 +2,23 @@
 
 python3_all = py3versions -s | xargs -n1 | xargs -t -I {} env {}
 
+ifeq ($(shell dpkg-architecture -qDEB_HOST_ARCH),arm64)
+       NOTMUCH_SKIP_TESTS=T460-emacs-tree
+       export NOTMUCH_SKIP_TESTS
+endif
+
 %:
        dh $@ --with python2,python3,elpa
 
 override_dh_auto_configure:
-       ./configure --prefix=/usr \
+       BASH=/bin/bash  ./configure --prefix=/usr \
                --libdir=/usr/lib/$$(dpkg-architecture -q DEB_TARGET_MULTIARCH) \
                --includedir=/usr/include \
                --mandir=/usr/share/man \
                --infodir=/usr/share/info \
                --sysconfdir=/etc \
-               --localstatedir=/var \
-               --emacslispdir=/usr/share/emacs/site-lisp/notmuch
+               --zshcompletiondir=/usr/share/zsh/vendor-completions \
+               --localstatedir=/var
 
 override_dh_auto_build:
        dh_auto_build -- V=1
@@ -32,7 +37,5 @@ override_dh_auto_install:
        dh_auto_install
        dh_auto_install --sourcedirectory bindings/python
        cd bindings/python && $(python3_all) setup.py install --install-layout=deb --root=$(CURDIR)/debian/tmp
+       $(MAKE) -C contrib/notmuch-mutt DESTDIR=$(CURDIR)/debian/tmp install
        dh_auto_install --sourcedirectory bindings/ruby
-
-override_dh_strip:
-       dh_strip --dbg-package notmuch-dbg