]> git.notmuchmail.org Git - notmuch/blobdiff - debian/rules
debian: skip T810-tsan on ppc64el
[notmuch] / debian / rules
index f9196b82612001ee89a4a1d5753c29901c9ba9d2..8bf97439866126532bd83ccb3b4a62e30b523a14 100755 (executable)
@@ -1,4 +1,9 @@
 #!/usr/bin/make -f
+include /usr/share/dpkg/architecture.mk
+
+ifeq ($(DEB_HOST_ARCH),ppc64el)
+       export NOTMUCH_SKIP_TESTS = T810-tsan
+endif
 
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
@@ -7,7 +12,7 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
 override_dh_auto_configure:
        BASHCMD=/bin/bash ./configure --prefix=/usr \
-               --libdir=/usr/lib/$$(dpkg-architecture -q DEB_TARGET_MULTIARCH) \
+               --libdir=/usr/lib/${DEB_TARGET_MULTIARCH} \
                --includedir=/usr/include \
                --mandir=/usr/share/man \
                --infodir=/usr/share/info \