]> git.notmuchmail.org Git - notmuch/blobdiff - debian/rules
debian/backports: disable test T460-emacs-tree on arm64
[notmuch] / debian / rules
index 04f0062a53ab992eb8f0f927a7644ab1a48d128a..abd5d8cf9cebc6d20e99db2ea18c15b7675b90dc 100755 (executable)
@@ -2,8 +2,13 @@
 
 python3_all = py3versions -s | xargs -n1 | xargs -t -I {} env {}
 
+ifeq ($(shell dpkg-architecture -qDEB_HOST_ARCH),arm64)
+       NOTMUCH_SKIP_TESTS=T460-emacs-tree
+       export NOTMUCH_SKIP_TESTS
+endif
+
 %:
-       dh $@ --with python2,python3
+       dh $@ --with python2,python3,elpa
 
 override_dh_auto_configure:
        ./configure --prefix=/usr \
@@ -12,8 +17,7 @@ override_dh_auto_configure:
                --mandir=/usr/share/man \
                --infodir=/usr/share/info \
                --sysconfdir=/etc \
-               --localstatedir=/var \
-               --emacslispdir=/usr/share/emacs/site-lisp/notmuch
+               --localstatedir=/var
 
 override_dh_auto_build:
        dh_auto_build -- V=1
@@ -33,6 +37,3 @@ override_dh_auto_install:
        dh_auto_install --sourcedirectory bindings/python
        cd bindings/python && $(python3_all) setup.py install --install-layout=deb --root=$(CURDIR)/debian/tmp
        dh_auto_install --sourcedirectory bindings/ruby
-
-override_dh_strip:
-       dh_strip --dbg-package notmuch-dbg