]> git.notmuchmail.org Git - notmuch/blobdiff - debian/rules
debian/backports: disable test T460-emacs-tree on arm64
[notmuch] / debian / rules
index a915179b600717e13610d2c738fed7e61a798370..abd5d8cf9cebc6d20e99db2ea18c15b7675b90dc 100755 (executable)
@@ -2,6 +2,11 @@
 
 python3_all = py3versions -s | xargs -n1 | xargs -t -I {} env {}
 
+ifeq ($(shell dpkg-architecture -qDEB_HOST_ARCH),arm64)
+       NOTMUCH_SKIP_TESTS=T460-emacs-tree
+       export NOTMUCH_SKIP_TESTS
+endif
+
 %:
        dh $@ --with python2,python3,elpa
 
@@ -32,6 +37,3 @@ override_dh_auto_install:
        dh_auto_install --sourcedirectory bindings/python
        cd bindings/python && $(python3_all) setup.py install --install-layout=deb --root=$(CURDIR)/debian/tmp
        dh_auto_install --sourcedirectory bindings/ruby
-
-override_dh_strip:
-       dh_strip --dbg-package notmuch-dbg