]> git.notmuchmail.org Git - notmuch/blob - packaging/fedora/notmuch.spec
f5272db2a47a02a58ef056b9cf7f9e4638b6f520
[notmuch] / packaging / fedora / notmuch.spec
1 %global git 6b9a717c
2 %global date %(date +%Y%m%d)
3
4 # If you are doing a git snapshot:
5 #
6 # Release should be 1%{git}%{?dist}
7 # Source0 should be notmuch-%{version}-%{git}.tar.gz
8 # git version is generated by 'git show-ref --hash=8 HEAD'
9 #
10 # To create a tarball:
11 #
12 # git clone git://notmuchmail.org/git/notmuch
13 # cd notmuch
14 # git archive --format=tar --prefix=notmuch-0.4/ HEAD | gzip > notmuch-0.4-`git show-ref --hash=8 HEAD`.tar.gz
15 #
16
17 Name:           notmuch
18 Version:        0.15.2
19 Release:        1%{?dist}
20 Summary:        Thread-based email index, search and tagging
21
22 Group:          Applications/Internet
23 License:        GPLv3+
24 URL:            http://notmuchmail.org/
25
26 Source0:        http://notmuchmail.org/releases/notmuch-%{version}.tar.gz
27
28 BuildRequires:  xapian-core-devel gmime-devel libtalloc-devel
29 BuildRequires:  zlib-devel emacs-el emacs-nox
30
31 Requires:       emacs(bin) >= %{_emacs_version}
32
33 %description
34 Fast system for indexing, searching, and tagging email.  Even if you
35 receive 12000 messages per month or have on the order of millions of
36 messages that you've been saving for decades, Notmuch will be able to
37 quickly search all of it.
38
39 Notmuch is not much of an email program. It doesn't receive messages
40 (no POP or IMAP support). It doesn't send messages (no mail composer,
41 no network code at all). And for what it does do (email search) that
42 work is provided by an external library, Xapian. So if Notmuch
43 provides no user interface and Xapian does all the heavy lifting, then
44 what's left here? Not much.
45
46 %package devel
47 Summary:        Development libraries and header files for %{name}
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 The %{name}-devel package contains libraries and header files for
53 developing applications that use %{name}.
54
55 %prep
56 %setup -q
57
58 %build
59 ./configure --prefix=%{_prefix} --libdir=%{_libdir} --sysconfdir=%{_sysconfdir} \
60     --mandir=%{_mandir} --includedir=%{_includedir} --emacslispdir=%{_emacs_sitelispdir}
61 make %{?_smp_mflags} CFLAGS="%{optflags}"
62
63 %install
64 make install DESTDIR=%{buildroot}
65
66 %post -p /sbin/ldconfig
67
68 %postun -p /sbin/ldconfig
69
70 %files
71 %doc AUTHORS COPYING COPYING-GPL-3 INSTALL README
72 %{_sysconfdir}/bash_completion.d/notmuch
73 %{_datadir}/zsh/functions/Completion/Unix/_notmuch
74 %{_bindir}/notmuch
75 %{_mandir}/man?/*
76 %{_libdir}/libnotmuch.so.3*
77
78 %{_emacs_sitelispdir}/*
79
80 %files devel
81 %{_libdir}/libnotmuch.so
82 %{_includedir}/*
83
84 %changelog
85 * Sun Apr 28 2013 Felipe Contreras <felipe.contreras@gmail.com> - 0.15.2-1
86 - Update to latest upstream
87
88 * Tue Nov  2 2010 Scott Henson <shenson@redhat.com> - 0.4-1
89 - New upstream release
90
91 * Wed Nov 18 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.0-0.3.306635c2
92 - First version
93