]> git.notmuchmail.org Git - notmuch/blobdiff - bindings/python-cffi/setup.py
bindings/python-cffi: copy version file into bindings dir
[notmuch] / bindings / python-cffi / setup.py
index 1effcfc6feec93a7528d95819bc445f66c42a9b6..b00608358f45e160e468f7f168d7f694f941f1d6 100644 (file)
@@ -1,14 +1,8 @@
-import pathlib
-
 import setuptools
 
-
-THIS_FILE = pathlib.Path(__file__).absolute()
-PROJECT_ROOT = THIS_FILE.parent.parent.parent
-with open(PROJECT_ROOT.joinpath('version')) as fp:
+with open('version') as fp:
     VERSION = fp.read().strip()
 
-
 setuptools.setup(
     name='notmuch2',
     version=VERSION,