]> git.notmuchmail.org Git - notmuch/blobdiff - bindings/python/setup.py
python: Have setup.py read the version number without importing
[notmuch] / bindings / python / setup.py
index 16de76aad80cdba1c6df977cb7b6a1709b7c69e0..286fd1962187b6351036d54d547e69dd9c0b1016 100644 (file)
@@ -4,18 +4,11 @@ import os
 import re
 from distutils.core import setup
 
-def get_version():
-    file = open('notmuch/__init__.py')
-    try:
-        for line in file:
-            if re.match('__VERSION__\s*=\s*',line) != None:
-                version = line.split('=', 1)[1]
-                return eval(version, {}, {})
-    finally:
-        file.close()
-    raise IOError('Unexpected end-of-file')
-
-__VERSION__=get_version()
+# get the notmuch version number without importing the notmuch module
+version_file = os.path.join(os.path.dirname(os.path.abspath(__file__)),
+                            'notmuch', 'version.py')
+execfile(version_file)
+assert __VERSION__, 'Failed to read the notmuch binding version number'
 
 setup(name='notmuch',
       version=__VERSION__,