]> git.notmuchmail.org Git - notmuch/blobdiff - bindings/python/setup.py
Merge branch 'master' of ssh://notmuchmail.org/git/notmuch
[notmuch] / bindings / python / setup.py
index e4a3a251b260036e0d496661e6fe02238eed096d..19b65584e427385f4f4b172cb26c0e5bd2ba6712 100644 (file)
@@ -1,14 +1,20 @@
 #!/usr/bin/env python
 
+import os
+import re
+import sys
 from distutils.core import setup
-from notmuch import __VERSION__
+dirname = os.path.dirname(os.path.abspath(__file__)) # Package's main folder
+sys.path.insert(0, dirname)
+import notmuch
+
 setup(name='notmuch',
-      version=__VERSION__,
+      version=notmuch.__VERSION__,
       description='Python binding of the notmuch mail search and indexing library.',
       author='Sebastian Spaeth',
       author_email='Sebastian@SSpaeth.de',
       url='http://notmuchmail.org/',
-      download_url='http://notmuchmail.org/releases/notmuch-'+__VERSION__+'.tar.gz',
+      download_url='http://notmuchmail.org/releases/notmuch-'+ notmuch.__VERSION__+'.tar.gz',
       packages=['notmuch'],
       keywords = ["library", "email"],
       long_description="""Overview
@@ -38,12 +44,11 @@ left of cnotmuch then.
 Requirements
 ------------
 
-You need to have notmuch installed (or rather libnotmuch.so.1). The
-release version 0.3 should work fine. Also, notmuch makes use of the
-ctypes library, and has only been tested with python 2.5. It will not
-work on earlier python versions.
+You need to have notmuch installed (or rather libnotmuch.so.1). Also,
+notmuch makes use of the ctypes library, and has only been tested with
+python >= 2.5. It will not work on earlier python versions.
 """,
-      classifiers=['Development Status :: 2 - Pre-Alpha',
+      classifiers=['Development Status :: 3 - Alpha',
                    'Intended Audience :: Developers',
                    'License :: OSI Approved :: GNU General Public License (GPL)',
                    'Programming Language :: Python :: 2',