]> git.notmuchmail.org Git - notmuch/blobdiff - bindings/python/setup.py
python: improve Query.count_messages docstring
[notmuch] / bindings / python / setup.py
index 19b65584e427385f4f4b172cb26c0e5bd2ba6712..2e58dab1d6a6cc3a6193031f2410b082e385b9eb 100644 (file)
@@ -2,19 +2,21 @@
 
 import os
 import re
-import sys
 from distutils.core import setup
-dirname = os.path.dirname(os.path.abspath(__file__)) # Package's main folder
-sys.path.insert(0, dirname)
-import notmuch
+
+# get the notmuch version number without importing the notmuch module
+version_file = os.path.join(os.path.dirname(os.path.abspath(__file__)),
+                            'notmuch', 'version.py')
+exec(compile(open(version_file).read(), version_file, 'exec'))
+assert __VERSION__, 'Failed to read the notmuch binding version number'
 
 setup(name='notmuch',
-      version=notmuch.__VERSION__,
+      version=__VERSION__,
       description='Python binding of the notmuch mail search and indexing library.',
       author='Sebastian Spaeth',
       author_email='Sebastian@SSpaeth.de',
       url='http://notmuchmail.org/',
-      download_url='http://notmuchmail.org/releases/notmuch-'+ notmuch.__VERSION__+'.tar.gz',
+      download_url='http://notmuchmail.org/releases/notmuch-'+__VERSION__+'.tar.gz',
       packages=['notmuch'],
       keywords = ["library", "email"],
       long_description="""Overview