]> git.notmuchmail.org Git - notmuch/blobdiff - bindings/python/setup.py
py3k: The ConfigParser module has been renamed to configparser
[notmuch] / bindings / python / setup.py
index e4a3a251b260036e0d496661e6fe02238eed096d..2e58dab1d6a6cc3a6193031f2410b082e385b9eb 100644 (file)
@@ -1,7 +1,15 @@
 #!/usr/bin/env python
 
+import os
+import re
 from distutils.core import setup
-from notmuch import __VERSION__
+
+# get the notmuch version number without importing the notmuch module
+version_file = os.path.join(os.path.dirname(os.path.abspath(__file__)),
+                            'notmuch', 'version.py')
+exec(compile(open(version_file).read(), version_file, 'exec'))
+assert __VERSION__, 'Failed to read the notmuch binding version number'
+
 setup(name='notmuch',
       version=__VERSION__,
       description='Python binding of the notmuch mail search and indexing library.',
@@ -38,12 +46,11 @@ left of cnotmuch then.
 Requirements
 ------------
 
-You need to have notmuch installed (or rather libnotmuch.so.1). The
-release version 0.3 should work fine. Also, notmuch makes use of the
-ctypes library, and has only been tested with python 2.5. It will not
-work on earlier python versions.
+You need to have notmuch installed (or rather libnotmuch.so.1). Also,
+notmuch makes use of the ctypes library, and has only been tested with
+python >= 2.5. It will not work on earlier python versions.
 """,
-      classifiers=['Development Status :: 2 - Pre-Alpha',
+      classifiers=['Development Status :: 3 - Alpha',
                    'Intended Audience :: Developers',
                    'License :: OSI Approved :: GNU General Public License (GPL)',
                    'Programming Language :: Python :: 2',