]> git.notmuchmail.org Git - notmuch/blobdiff - bindings/python/setup.py
python: simplify a path expression in setup.py
[notmuch] / bindings / python / setup.py
index 2e58dab1d6a6cc3a6193031f2410b082e385b9eb..b46ac8dd07ca99b4985f145a2883e4f71274ed4a 100644 (file)
@@ -1,11 +1,10 @@
 #!/usr/bin/env python
 
 import os
-import re
 from distutils.core import setup
 
 # get the notmuch version number without importing the notmuch module
-version_file = os.path.join(os.path.dirname(os.path.abspath(__file__)),
+version_file = os.path.join(os.path.dirname(__file__),
                             'notmuch', 'version.py')
 exec(compile(open(version_file).read(), version_file, 'exec'))
 assert __VERSION__, 'Failed to read the notmuch binding version number'