]> git.notmuchmail.org Git - notmuch/blobdiff - debian/rules
Merge branch 'release'
[notmuch] / debian / rules
index 1ac6498ca49fb8e50c4cb9caa79904d36621951d..ebd1048170839dfc90aa75c789b1669af252bee2 100755 (executable)
@@ -2,16 +2,19 @@
 
 python3_all = py3versions -s | xargs -n1 | xargs -t -I {} env {}
 
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
 %:
        dh $@ --with python2,python3,elpa
 
 override_dh_auto_configure:
-       ./configure --prefix=/usr \
+       BASHCMD=/bin/bash ./configure --prefix=/usr \
                --libdir=/usr/lib/$$(dpkg-architecture -q DEB_TARGET_MULTIARCH) \
                --includedir=/usr/include \
                --mandir=/usr/share/man \
                --infodir=/usr/share/info \
                --sysconfdir=/etc \
+               --zshcompletiondir=/usr/share/zsh/vendor-completions \
                --localstatedir=/var
 
 override_dh_auto_build:
@@ -31,4 +34,5 @@ override_dh_auto_install:
        dh_auto_install
        dh_auto_install --sourcedirectory bindings/python
        cd bindings/python && $(python3_all) setup.py install --install-layout=deb --root=$(CURDIR)/debian/tmp
+       $(MAKE) -C contrib/notmuch-mutt DESTDIR=$(CURDIR)/debian/tmp install
        dh_auto_install --sourcedirectory bindings/ruby