NEWS: At least Emacs 25.1 is required now
authorJonas Bernoulli <jonas@bernoul.li>
Sat, 8 Aug 2020 11:50:02 +0000 (13:50 +0200)
committerDavid Bremner <david@tethera.net>
Mon, 10 Aug 2020 00:14:36 +0000 (21:14 -0300)
Some backward incompatible changes follow in the next few commits
and going forward contributors don't have to worry about Emacs 24
at all anymore.

NEWS
emacs/notmuch-pkg.el.tmpl

diff --git a/NEWS b/NEWS
index 3790204b427c12bac6b373e054341707cbb068f5..4160e39c9c30c90fa16aa295ba201005916d515e 100644 (file)
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,11 @@
 Notmuch 0.31 (UNRELEASED)
 =========================
 
+Emacs
+-----
+
+The minimum supported major version of GNU Emacs is now 25.1.
+
 Notmuch 0.30 (2020-07-10)
 =========================
 
index 9d0999c122a9e20e2189766d0b600a3016458df7..85c631de39e1128365bc1dae3d88b54b7708c4ac 100644 (file)
@@ -3,5 +3,4 @@
   "notmuch"
   %VERSION%
   "Emacs based front-end (MUA) for notmuch"
-  '((emacs "24")
-    (cl-lib "0.6.1")))
+  '((emacs "25.1")))