Update notmuch-mutt requirements in README file.