python: improve Query.count_messages docstring
[notmuch] / bindings / python / setup.py
1 #!/usr/bin/env python
2
3 import os
4 import re
5 from distutils.core import setup
6
7 # get the notmuch version number without importing the notmuch module
8 version_file = os.path.join(os.path.dirname(os.path.abspath(__file__)),
9                             'notmuch', 'version.py')
10 exec(compile(open(version_file).read(), version_file, 'exec'))
11 assert __VERSION__, 'Failed to read the notmuch binding version number'
12
13 setup(name='notmuch',
14       version=__VERSION__,
15       description='Python binding of the notmuch mail search and indexing library.',
16       author='Sebastian Spaeth',
17       author_email='Sebastian@SSpaeth.de',
18       url='http://notmuchmail.org/',
19       download_url='http://notmuchmail.org/releases/notmuch-'+__VERSION__+'.tar.gz',
20       packages=['notmuch'],
21       keywords = ["library", "email"],
22       long_description="""Overview
23 ==============
24
25 The notmuch  module provides an interface to the `notmuch <http://notmuchmail.org>`_ functionality, directly interfacing with a shared notmuch library. Notmuch provides a maildatabase that allows for extremely quick searching and filtering of your email according to various criteria.
26
27 The documentation for the latest cnotmuch release can be `viewed online <http://packages.python.org/notmuch>`_.
28
29 The classes notmuch.Database, notmuch.Query  provide most of the core functionality, returning notmuch.Messages and notmuch.Tags.
30
31 Installation and Deinstallation
32 -------------------------------
33
34 notmuch is included in the upstream notmuch source repository and it is
35 packaged on http://pypi.python.org. This means you can do "easy_install
36 notmuch" (or using pip) on your linux box and it will get installed
37 into:
38
39 /usr/local/lib/python2.x/dist-packages/
40
41 For uninstalling, you will need to remove the "notmuch-0.x-py2.x.egg"
42 directory and delete one entry refering to cnotmuch in the
43 "easy-install.pth" file in that directory. There should be no trace
44 left of cnotmuch then.
45
46 Requirements
47 ------------
48
49 You need to have notmuch installed (or rather libnotmuch.so.1). Also,
50 notmuch makes use of the ctypes library, and has only been tested with
51 python >= 2.5. It will not work on earlier python versions.
52 """,
53       classifiers=['Development Status :: 3 - Alpha',
54                    'Intended Audience :: Developers',
55                    'License :: OSI Approved :: GNU General Public License (GPL)',
56                    'Programming Language :: Python :: 2',
57                    'Programming Language :: Python :: 3',
58                    'Topic :: Communications :: Email',
59                    'Topic :: Software Development :: Libraries'
60                    ],
61       platforms='',
62       license='http://www.gnu.org/licenses/gpl-3.0.txt',
63      )