]> git.notmuchmail.org Git - notmuch/blobdiff - bindings/python-cffi/setup.py
emacs: Add new option notmuch-search-hide-excluded
[notmuch] / bindings / python-cffi / setup.py
index 1effcfc6feec93a7528d95819bc445f66c42a9b6..55fb2d24f832b49e2730db879309b441a58a0a78 100644 (file)
@@ -1,14 +1,9 @@
-import pathlib
-
 import setuptools
+from _notmuch_config import *
 
-
-THIS_FILE = pathlib.Path(__file__).absolute()
-PROJECT_ROOT = THIS_FILE.parent.parent.parent
-with open(PROJECT_ROOT.joinpath('version')) as fp:
+with open(NOTMUCH_VERSION_FILE) as fp:
     VERSION = fp.read().strip()
 
-
 setuptools.setup(
     name='notmuch2',
     version=VERSION,