]> git.notmuchmail.org Git - notmuch/blobdiff - bindings/python-cffi/setup.py
emacs: Add new option notmuch-search-hide-excluded
[notmuch] / bindings / python-cffi / setup.py
index 7baf63cf528910be145d65791c69ae0c2fae5763..55fb2d24f832b49e2730db879309b441a58a0a78 100644 (file)
@@ -1,16 +1,19 @@
 import setuptools
+from _notmuch_config import *
 
+with open(NOTMUCH_VERSION_FILE) as fp:
+    VERSION = fp.read().strip()
 
 setuptools.setup(
-    name='notdb',
-    version='0.1',
+    name='notmuch2',
+    version=VERSION,
     description='Pythonic bindings for the notmuch mail database using CFFI',
     author='Floris Bruynooghe',
     author_email='flub@devork.be',
     setup_requires=['cffi>=1.0.0'],
     install_requires=['cffi>=1.0.0'],
     packages=setuptools.find_packages(exclude=['tests']),
-    cffi_modules=['notdb/_build.py:ffibuilder'],
+    cffi_modules=['notmuch2/_build.py:ffibuilder'],
     classifiers=[
         'Development Status :: 3 - Alpha',
         'Intended Audience :: Developers',