]> git.notmuchmail.org Git - notmuch/blobdiff - bindings/python/setup.py
NEWS, python: update pointer to online documentation
[notmuch] / bindings / python / setup.py
index 97c284fc2e431c516cc932ce2f94f1c880791eb5..ba95d951ba2046fc9941650336fdcdec1ff99444 100644 (file)
@@ -1,5 +1,24 @@
 #!/usr/bin/env python
 
+"""
+This file is part of notmuch.
+
+Notmuch is free software: you can redistribute it and/or modify it
+under the terms of the GNU General Public License as published by the
+Free Software Foundation, either version 3 of the License, or (at your
+option) any later version.
+
+Notmuch is distributed in the hope that it will be useful, but WITHOUT
+ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License
+for more details.
+
+You should have received a copy of the GNU General Public License
+along with notmuch.  If not, see <http://www.gnu.org/licenses/>.
+
+Copyright 2010 Sebastian Spaeth <Sebastian@SSpaeth.de>
+"""
+
 import os
 from distutils.core import setup
 
@@ -16,10 +35,10 @@ setup(name='notmuch',
       author='Sebastian Spaeth',
       author_email='Sebastian@SSpaeth.de',
       url='http://notmuchmail.org/',
-      download_url='http://notmuchmail.org/releases/notmuch-'+__VERSION__+'.tar.gz',
+      download_url='http://notmuchmail.org/releases/notmuch-%s.tar.gz' % __VERSION__,
       packages=['notmuch'],
-      keywords = ["library", "email"],
-      long_description="""Overview
+      keywords=['library', 'email'],
+      long_description='''Overview
 ========
 
 The notmuch module provides an interface to the `notmuch
@@ -29,7 +48,7 @@ for extremely quick searching and filtering of your email according to
 various criteria.
 
 The documentation for the latest notmuch release can be `viewed
-online <http://notmuch.readthedocs.org/>`_.
+online <https://notmuch.readthedocs.io/>`_.
 
 Requirements
 ------------
@@ -37,7 +56,7 @@ Requirements
 You need to have notmuch installed (or rather libnotmuch.so.1). Also,
 notmuch makes use of the ctypes library, and has only been tested with
 python >= 2.5. It will not work on earlier python versions.
-""",
+''',
       classifiers=['Development Status :: 3 - Alpha',
                    'Intended Audience :: Developers',
                    'License :: OSI Approved :: GNU General Public License (GPL)',