]> git.notmuchmail.org Git - notmuch/blobdiff - debian/rules
debian: Add a gbp.conf to start using git-buildpackage
[notmuch] / debian / rules
index 3b44e0f12ae182261ca92d06ee0868a2a5684804..4dae6583e4d4e4cf56fd9d46a97357330f457242 100755 (executable)
@@ -1,4 +1,11 @@
 #!/usr/bin/make -f
+
+# This target invoked by git-buildpackage using a clean hook, see gbp.conf
+prebuild:
+       git-dch --release --new-version=$(VERSION)
+       git commit -n debian/changelog \
+               -m "Automatically update debian/changelog for $(VERSION)"
+
 %:
        dh $@