]> git.notmuchmail.org Git - notmuch/blobdiff - debian/rules
debian: Add a gbp.conf to start using git-buildpackage
[notmuch] / debian / rules
index cbe925d7587131c8ec8761915930894c60c096fd..4dae6583e4d4e4cf56fd9d46a97357330f457242 100755 (executable)
@@ -1,3 +1,23 @@
 #!/usr/bin/make -f
+
+# This target invoked by git-buildpackage using a clean hook, see gbp.conf
+prebuild:
+       git-dch --release --new-version=$(VERSION)
+       git commit -n debian/changelog \
+               -m "Automatically update debian/changelog for $(VERSION)"
+
 %:
        dh $@
+
+override_dh_auto_configure:
+       dh_auto_configure -- --emacslispdir=/usr/share/emacs/site-lisp/notmuch
+
+override_dh_installdocs:
+       dh_installdocs
+       install -m644 vim/README debian/notmuch/usr/share/doc/notmuch/README.vim
+
+override_dh_install:
+       dh_install
+       install -m644 vim/plugin/notmuch.vim debian/notmuch/usr/share/vim/addons/plugin
+       install -m644 vim/syntax/notmuch-*.vim debian/notmuch/usr/share/vim/addons/syntax
+       install -m644 vim/notmuch.yaml debian/notmuch/usr/share/vim/registry