]> git.notmuchmail.org Git - notmuch/blobdiff - debian/rules
debian upload 0.29.2-2: goodbye python2 support
[notmuch] / debian / rules
index a915179b600717e13610d2c738fed7e61a798370..5a378f6e6fc4285c9a08139b9f2b8beb383fda9f 100755 (executable)
@@ -1,37 +1,33 @@
 #!/usr/bin/make -f
 
-python3_all = py3versions -s | xargs -n1 | xargs -t -I {} env {}
+export PYBUILD_NAME=notmuch
 
 %:
-       dh $@ --with python2,python3,elpa
+       dh $@ --with python3,elpa
 
 override_dh_auto_configure:
-       ./configure --prefix=/usr \
+       BASHCMD=/bin/bash ./configure --prefix=/usr \
                --libdir=/usr/lib/$$(dpkg-architecture -q DEB_TARGET_MULTIARCH) \
                --includedir=/usr/include \
                --mandir=/usr/share/man \
                --infodir=/usr/share/info \
                --sysconfdir=/etc \
+               --zshcompletiondir=/usr/share/zsh/vendor-completions \
                --localstatedir=/var
 
 override_dh_auto_build:
        dh_auto_build -- V=1
-       dh_auto_build --sourcedirectory bindings/python
-       cd bindings/python && $(python3_all) setup.py build
+       dh_auto_build --buildsystem=pybuild --sourcedirectory bindings/python
        $(MAKE) -C contrib/notmuch-mutt
 
 override_dh_auto_clean:
        dh_auto_clean
-       dh_auto_clean --sourcedirectory bindings/python
-       cd bindings/python && $(python3_all) setup.py clean -a
+       dh_auto_clean --buildsystem=pybuild --sourcedirectory bindings/python
        dh_auto_clean --sourcedirectory bindings/ruby
        $(MAKE) -C contrib/notmuch-mutt clean
 
 override_dh_auto_install:
        dh_auto_install
-       dh_auto_install --sourcedirectory bindings/python
-       cd bindings/python && $(python3_all) setup.py install --install-layout=deb --root=$(CURDIR)/debian/tmp
+       dh_auto_install --buildsystem=pybuild --sourcedirectory bindings/python
+       $(MAKE) -C contrib/notmuch-mutt DESTDIR=$(CURDIR)/debian/tmp install
        dh_auto_install --sourcedirectory bindings/ruby
-
-override_dh_strip:
-       dh_strip --dbg-package notmuch-dbg