]> git.notmuchmail.org Git - notmuch/blobdiff - debian/rules
debian: Add package for debugging symbols (Closes: #717339)
[notmuch] / debian / rules
index 4dae6583e4d4e4cf56fd9d46a97357330f457242..7a19445e93a2a3f1882c4f339bc525643fa2b126 100755 (executable)
@@ -1,23 +1,32 @@
 #!/usr/bin/make -f
 
-# This target invoked by git-buildpackage using a clean hook, see gbp.conf
-prebuild:
-       git-dch --release --new-version=$(VERSION)
-       git commit -n debian/changelog \
-               -m "Automatically update debian/changelog for $(VERSION)"
+python3_all = py3versions -s | xargs -n1 | xargs -t -I {} env {}
 
 %:
-       dh $@
+       dh $@ --with python2,python3
 
 override_dh_auto_configure:
        dh_auto_configure -- --emacslispdir=/usr/share/emacs/site-lisp/notmuch
 
-override_dh_installdocs:
-       dh_installdocs
-       install -m644 vim/README debian/notmuch/usr/share/doc/notmuch/README.vim
+override_dh_auto_build:
+       dh_auto_build -- V=1
+       dh_auto_build --sourcedirectory bindings/python
+       cd bindings/python && $(python3_all) setup.py build
+       cd bindings/ruby && ruby extconf.rb --vendor && make
+       $(MAKE) -C contrib/notmuch-mutt
 
-override_dh_install:
-       dh_install
-       install -m644 vim/plugin/notmuch.vim debian/notmuch/usr/share/vim/addons/plugin
-       install -m644 vim/syntax/notmuch-*.vim debian/notmuch/usr/share/vim/addons/syntax
-       install -m644 vim/notmuch.yaml debian/notmuch/usr/share/vim/registry
+override_dh_auto_clean:
+       dh_auto_clean
+       dh_auto_clean --sourcedirectory bindings/python
+       cd bindings/python && $(python3_all) setup.py clean -a
+       dh_auto_clean --sourcedirectory bindings/ruby
+       $(MAKE) -C contrib/notmuch-mutt clean
+
+override_dh_auto_install:
+       dh_auto_install
+       dh_auto_install --sourcedirectory bindings/python
+       cd bindings/python && $(python3_all) setup.py install --install-layout=deb --root=$(CURDIR)/debian/tmp
+       dh_auto_install --sourcedirectory bindings/ruby
+
+override_dh_strip:
+       dh_strip --dbg-package notmuch-dbg