try-emacs-mua: Trim `require' advice for Emacs 25
[notmuch] / debian / NEWS
1 notmuch (0.21~rc1-1) experimental; urgency=medium
2
3   This release of notmuch requires a non-reversible database upgrade
4   to support database revision tracking. This upgrade will happen on
5   the first run of 'notmuch-new' after updating. Notmuch will backup
6   your tags for your before doing the upgrade, but it never hurts to
7   make your own backup with notmuch dump.
8
9  -- David Bremner <bremner@debian.org>  Thu, 15 Oct 2015 08:13:04 -0300
10
11 notmuch (0.19-1) experimental; urgency=medium
12
13   This release of notmuch again requires a non-reversable database
14   upgrade to support database features. This upgrade will happen on
15   the first run of 'notmuch-new' after updating. Notmuch will backup
16   your tags for your before doing the upgrade, but it never hurts to
17   make your own backup with notmuch dump.
18
19  -- David Bremner <bremner@debian.org>  Fri, 14 Nov 2014 20:34:55 +0100
20
21 notmuch (0.18~rc0-1) experimental; urgency=low
22
23   This release of notmuch requires a non-reversable database upgrade
24   to support the new path: and updated folder: prefixes. Notmuch
25   will backup your tags for your before doing the upgrade, but it
26   never hurts to make your own backup with notmuch dump before
27   next running 'notmuch new'
28
29  -- David Bremner <bremner@debian.org>  Tue, 22 Apr 2014 09:32:11 +0900
30
31 notmuch (0.17-1) unstable; urgency=low
32
33   Previously on big endian architectures like sparc and powerpc the
34   computation of SHA1 hashes was incorrect. This meant that messages
35   with overlong or missing message-ids were given different computed
36   message-ids than on more common little endian architectures like
37   i386 and amd64.  If you use notmuch on a big endian architecture,
38   you are strongly advised to make a backup of your tags using
39   `notmuch dump` before this upgrade.  You can locate the affected
40   files using something like:
41
42   notmuch dump | \
43     awk '/^notmuch-sha1-[0-9a-f]{40} / \
44       {system("notmuch search --exclude=false --output=files id:" $1)}'
45
46  -- David Bremner <bremner@debian.org>  Mon, 30 Dec 2013 20:31:16 -0400
47
48 notmuch (0.16-1) unstable; urgency=low
49
50   The vim interface has been rewritten from scratch. In particular
51   it requires a version of vim with ruby support.
52
53  -- David Bremner <bremner@debian.org>  Sat, 16 Feb 2013 08:12:02 -0400
54
55 notmuch (0.14-1) unstable; urgency=low
56
57   There is an incompatible change in option syntax for dump and restore
58   in this release. Please update your scripts.
59
60   From upstream NEWS:
61
62   The deprecated positional output file argument to notmuch dump has
63   been replaced with an --output option. The input file positional
64   argument for restore has been replaced with an --input option for
65   consistency with dump.
66
67  -- David Bremner <bremner@debian.org>  Sun, 05 Aug 2012 11:52:49 -0300
68
69 notmuch (0.6~238) unstable; urgency=low
70
71   The emacs user interface to notmuch is now contained in a separate
72   package called notmuch-emacs.
73
74  -- David Bremner <bremner@debian.org>  Mon, 20 Jun 2011 23:57:55 -0300