debian/compat: upgrade to compat level 9
authorDavid Bremner <bremner@debian.org>
Sun, 25 Nov 2012 19:40:22 +0000 (15:40 -0400)
committerDavid Bremner <bremner@debian.org>
Tue, 15 Jan 2013 01:01:39 +0000 (21:01 -0400)
- enable hardening

- fix dh syntax. Now that we have compat level 9, the old, wrong
  syntax is no longer accepted.

- update debian/libnotmuch{3,-dev}.install for multiarch.

- update versioned dependency on debhelper.

debian/compat
debian/control
debian/libnotmuch-dev.install
debian/libnotmuch3.install
debian/rules

index 7f8f011eb73d6043d2e6db9d2c101195ae2801f2..ec635144f60048986bc560c5576355344005e6e7 100644 (file)
@@ -1 +1 @@
-7
+9
index d434c53dd3f48cb40fb6bf8888a8ab3c8116e6a6..75b55a5c4c55c9020f0ad27baf9a4cac7f2bfaf7 100644 (file)
@@ -7,7 +7,7 @@ Uploaders:
  martin f. krafft <madduck@debian.org>,
  David Bremner <bremner@debian.org>
 Build-Depends:
  martin f. krafft <madduck@debian.org>,
  David Bremner <bremner@debian.org>
 Build-Depends:
- debhelper (>= 7.0.50~),
+ debhelper (>= 9),
  pkg-config,
  libxapian-dev,
  libgmime-2.6-dev (>= 2.6.7~) | libgmime-2.4-dev,
  pkg-config,
  libxapian-dev,
  libgmime-2.6-dev (>= 2.6.7~) | libgmime-2.4-dev,
@@ -39,6 +39,7 @@ Package: libnotmuch3
 Section: libs
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
 Section: libs
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}
+Pre-Depends: ${misc:Pre-Depends}
 Description: thread-based email index, search and tagging (runtime)
  Notmuch is a system for indexing, searching, reading, and tagging
  large collections of email messages in maildir or mh format. It uses
 Description: thread-based email index, search and tagging (runtime)
  Notmuch is a system for indexing, searching, reading, and tagging
  large collections of email messages in maildir or mh format. It uses
index 185dba4e32281492b9a594c175ee1666d5b0b720..96bbd63fe920e732114b28f47d515e953b138988 100644 (file)
@@ -1,2 +1,2 @@
 usr/include
 usr/include
-usr/lib/libnotmuch.so
+usr/lib/*/libnotmuch.so
index da4fc25ba27172574ebd0c05721c49bd05f82e5b..a513b4757f05eb3fbf9370fb319967084ef43c1d 100644 (file)
@@ -1 +1 @@
-usr/lib/libnotmuch.so.*
+usr/lib/*/libnotmuch.so.*
index 603b3ab281a2bdd27f2073d3a988e1c5838c1fa6..8e303538a541feda90cadc33223bf7ef7065a55e 100755 (executable)
@@ -1,7 +1,7 @@
 #!/usr/bin/make -f
 
 %:
 #!/usr/bin/make -f
 
 %:
-       dh --with python2 $@
+       dh $@ --with python2
 
 override_dh_auto_configure:
        dh_auto_configure -- --emacslispdir=/usr/share/emacs/site-lisp/notmuch
 
 override_dh_auto_configure:
        dh_auto_configure -- --emacslispdir=/usr/share/emacs/site-lisp/notmuch