configure: Add explicit check for glib >= 2.14