configure: Add support for GMime 2.6