lib: Bump SO version from 2.0.0 to 3.0.0